Jump to content

88pro

Young DAC Driver with hiface M2Tech

Recommended Posts

After reading the below two links

http://www.digitalaudioreview.net.au/index.php/news-blog-and-showcase/john-darkos-blog/item/318-m2tech-young-dac-vs-jkdac32

https://sites.google.com/site/hifacemods/home/announcements/improvethesoundofmyhifacedevices

I wanted to try and use Young DAC driver with my MK3, I dont know how to do it on a Mac.

I went as far as uninstalling M2Tech Driver following these instructions I found on the web.

sudo mv /System/Library/Extensions/Hiface.kext /tmp

sudo touch /System/Library/Extensions

sudo pkgutil --forget com.m2tech.driver

Then I installed Young Driver however it doesn't show up on the Audio Midi setup on Mac.

I located extension file in /Library/Extensions/Young.extn and changed the messed around with the files but no luck.

Any Mac experts here who can help, pleaseeeee?

(Looks like both drivers are developed by two different companies based on the identifiers listed in info.plist)

Share this post


Link to post
Share on other sites

The problem is that the Hiface has a different ID code in it's firmware to the Young DAC & therefore looks for a driver that matches this code. In windows you can override this by firstly unchecking the box that says "only display drivers that match the hardware" & then the Young Driver will appear on the list of M2tech drivers available for assigning to the Hiface. Then when Windows warns that this driver may cause your hardware to malfunction, ignoring that warning & it will install the driver.

Unless you can find the equivalent procedure for the Mac you will not be able to use the Young driver. The only other option would be to change the Young driver ID to match the Hiface.

There are some Mac users here with sufficiently deep Mac knowledge to know how to do this or whether it's feasible on the Mac - I'm thinking of kdoot but there may be others?

Edited by jkeny

Share this post


Link to post
Share on other sites

Hi I use a Eastern Electric Minimax Plus DAC with a Mac Mini. That uses a modified version of the M2tech Driver. I installed the MAC version of the driver on MAC OS Lion. I am also using Audirvana plus. The M2 option only appears as a selectable option when the DAC is powered on and connected via USB. In that case I select it as the preferred output in audirvana plus.

If I was to go into audirvana settings whilst the DAC is off, the M2 option would not be available but as long as I do not change it from the default option, each time I power up the DAC audirvana sees it and shows the available outputs as 44,1 48 88.2 92 176 192 etc

I have never had to play around with sudo, and I believe the the EE driver is just a renamed M2tech driver

Edited by Demondes

Share this post


Link to post
Share on other sites

Of course the only other difference is the M2tech is internal in Mininmax plus where it is a separate device in your case

Share this post


Link to post
Share on other sites

Look at post 17 for simpler steps

Here are the steps to map the Young Driver to Hiface, on Max OS X Lion and Snow Leopard.

First uninstall hiface with below steps. Open Terminal and run the below command.

sudo mv /System/Library/Extensions/Hiface.kext /tmp

sudo touch /System/Library/Extensions

sudo pkgutil --forget com.m2tech.driver

Now download and install Young driver. Once installed.

Open 'Finder' and goto

/System/Library/Extensions

There you can locate the file 'Young.kext'

Right Click Young.kext and select 'Show Package Contents'

Insite 'Contents' folder you have two 'info.plist' files.

One plist directly under 'Contents' folder and the other 'Resources' folder

Below modification, you will have to do it in both files.

Open the info.plist file with a text editor.

Search for

<key>idProduct</key>

<integer>900</integer>

And replace with

<key>idProduct</key>

<integer>37643</integer>

And restart machine.

What we are basically doing is changing the product id of the USB driver from Young to Hiface. This will enable the OS to match the driver to hiface.

Dont worry about changing the Vendor ID since both devices are from the same vender and thus already share the same vendor id.

NOW DO THIS AT YOUR OWN RISK, AND IF ANYTHING SCREWS UP, I AM NOT RESPONSIBLE ;)

All these steps are easily reversible as you can reinstall the driver and everything should be back to normal.

[PS: If you are using Pure Music, Up sampling still up samples to 384khz and it doesn't work. However if you disable up sampling all is well.]

Edited by 88pro
Pointed towards post 17

Share this post


Link to post
Share on other sites


Removed the warning on my previous post about sample rate problem. It turns out I had select upsamppling option in Pure Music and it is trying upsample to 384khz. I tried to limit it in the Audio Midi to 192khz as well as in pure music with no luck.

However As soon as I removed upsampling, its all good. Will spend more time to figure out, how to get it working with upsampling.

Share this post


Link to post
Share on other sites

I believe the Young drivers are 32/384 so if Pure Music is sensing this & using it as the upsampling target rate, you might find the solution in that area. If your DAC is not capable of 384KHz then it will cause problems - the 32bits won't as they will be stripped down to 24 or 16bit

Share this post


Link to post
Share on other sites

Bad news ;)

I tried the same steps in Snow Leopard and no luck. Falling back on hiface driver on Snow Leopard for now.

May be this is something do with Snow Leopard being bit perfect while Lion is not? (I have no clue)

Share this post


Link to post
Share on other sites
Bad news ;)

I tried the same steps in Snow Leopard and no luck. Falling back on hiface driver on Snow Leopard for now.

May be this is something do with Snow Leopard being bit perfect while Lion is not? (I have no clue)

Are you sure it doesn't work, because all your doing is changing the drivers installation script ID to make it the same as the Hiface driver ID. Isn't that correct? Why would it not work in the latest OSX?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×