Jump to content

Grounded Grid pre-amp - duff channel


Recommended Posts

Hi there,

Seeking any/all guidance for diagnosis of cause(s) of a new problem with GG pre-amp.

I can easily check voltages and shorts etc. but wondering if the likely culprit(s) are the 12AU7 tubes. Happy to buy some more and swap out, but is there anything else I should check?

Don't really want to lob in new tubes for them just to fail because something else has gone shonky.

Have had no issues with the pre-amp for the last 9 years, and it was originally built really well by Gary Proudfoot gypr1961

Cheers,

TT

Link to post
Share on other sites

Describing the actual issue you are having,  will help.  Also if you can access a schematic diagram would be really good.

 

Usual things like scratchy sound can be traced to worn pots passing audio signal, or contacts on switches. next up the line is aging capacitors. noting contact-less methods of attenuation and switching are much better.  

 

The bathtub curve so named, gives reason why some parts wear out faster than others   https://en.wikipedia.org/wiki/Bathtub_curve

 

 

Link to post
Share on other sites
On 09/04/2021 at 10:43 AM, tassie tiger said:

Hi there,

Seeking any/all guidance for diagnosis of cause(s) of a new problem with GG pre-amp.

......

Have had no issues with the pre-amp for the last 9 years, and it was originally built really well by Gary Proudfoot gypr1961

Cheers,

TT

 

And therein is your answer.  Contact @gypr1961 and ask the question or obtain a schematic  of the pre-amp from him. 

Many here are able to assist, but diagnosis by proxy without a schematic is somewhat difficult.  :(

 

Cheers,

Alan R.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...