Jump to content

Strange behaviour on my epson projector


Recommended Posts

I was watching a movie on my epson 6700 when a scene suddenly changed. It was a dark scene but it looked as if a flood light turned on behind me. I even turned around to look but nothing was there. So maybe I thought this was what the scene was supposed to look like. Artistic or something. Almost a J.J Abrams overdone glare shot or something.
But it kept going, so I turned off the movie and the atv menu was the same. Very bright and colours washed out. Seemed worse in one spot. Checked settings and everything was normal so I Turned off the projector and when I turned it back on, all was well again... 

that’s great, but what happened? Is it failing or a one off? Anyone know?

Edited by christopher
Spelling
Link to post
Share on other sites

Did it look like one of the colours was amplified?  Not sure if the 6700 is a 3 LCD projector model but if it is, and one of the LCD panels loses power then you would see something like you are describing.  Might be the start of something bad.

Link to post
Share on other sites

It is a 3lcd. Can’t say I noticed one colour amplified. Seemed like I said, localised overly bright and washed out colour. I’ve used it a few times since without issue. If it happens again I’ll take a photo.

Link to post
Share on other sites

Not under warranty? Sounds like light engine failing.. how old is it?

Link to post
Share on other sites


  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...