Jump to content

NAD Masters M33 - Has anyone tried it with 800 Diamonds?


Recommended Posts

Not sure if this is the correct location to post this question.   

 

There are a few reviews around, but I haven't seen any with reference to the big Bowers and Wilkins.   Can anyone point me in the right direction?

 

I'm specifically interested in it's low impedance capabilities.   

Link to post
Share on other sites

I suspect there is limited stock of the M33 in the country.  Also, to widen the search for info, look for NAD C298 reviews and posts, using essentially the same Purifi technology. 

 

Link to post
Share on other sites

Ordered my m33 early in the year, originally expecting it March but the store only received 1 amp and ordered 2nd. Now expecting the amp April. Intention is to pair with my new 804’s which did arrive.

  • Like 2
Link to post
Share on other sites

Thanks for the replies.   

 

Very interested to look at the impedance graph for the 804s.   I really didn't expect the low of 2.4 ohms.  (Nom. 4 ohms) ( https://hometheaterreview.com/bowers-wilkins-804-d3-floorstanding-speakers-reviewed/ )

 

I imagine that the 804s won't suck as much current as my 800 D2s- but it looks like they are actually less efficient so that may not be the case!  

 

 

Link to post
Share on other sites


  • 1 month later...
On 17/03/2021 at 2:47 AM, Gav.H said:

Ordered my m33 early in the year, originally expecting it March but the store only received 1 amp and ordered 2nd. Now expecting the amp April. Intention is to pair with my new 804’s which did arrive.

I ordered 1 also , hoping for end of this month.

Link to post
Share on other sites
On 25/04/2021 at 5:34 PM, paking said:

I ordered 1 also , hoping for end of this month.

I got mine but……

C2BA94FE-A626-4DCF-AFF0-E0707F279C17.jpeg

Link to post
Share on other sites
Posted (edited)

When you do get it running.......what speakers do you have?

Edited by MusicForever
Link to post
Share on other sites


I haven’t got it running yet, gets halfway thru the update then 

goes to standby mode. Sent a requested to NAD for some help.

Still in the process with that. Will eventually connect to a pair of 

B&W CM9 Series One. Fingers crossed, don’t like my chances of 

getting a replacement now. Hopefully just a SW cliche.

 

Cheers Paul.

Link to post
Share on other sites
2 minutes ago, pcking said:

I haven’t got it running yet, gets halfway thru the update then 

goes to standby mode. Sent a requested to NAD for some help.

Still in the process with that. Will eventually connect to a pair of 

B&W CM9 Series One. Fingers crossed, don’t like my chances of 

getting a replacement now. Hopefully just a SW cliche.

 

Cheers Paul.

I had a software issue with my C298 that required it be sent back to NAD - they could not get the unit to take the update so replaced with a new unit running version 1.08.

 

Unit now sitting in the study unopened while I try to sell it.

Link to post
Share on other sites

Yes , hardwired to the router. Been using a Bluesound Powernode 2i

since December hardwired also , so it’s not a Network issue .

Might have to send back to Convoy International for repairs.

 

Link to post
Share on other sites


I'll be very interested to hear how it sounds compared to the Mac C47 that you have.....  

Link to post
Share on other sites

Well  I just Stream most of the time now and have sold all my sources CD Player etc.

So I will be 1st connecting straight to my speakers for a few weeks, then use the M33 Pre outs to my Mcintosh Amp and do a comparison.

So I might end up selling my Mcintosh Amp also. 

All the above depends on the NAD getting sorted out. 

 

Cheers Paul.

Link to post
Share on other sites

I've been trying to get a listen to the M10 and the M33.  None of the dealers in Brissie- that I have approached- has one to listen to.  (Trimira/ Audio Tailor etc...)   The Audio Tailor suggested the Hegel 190 but, as well regarded as they are, I have no interest in any device that doesn't have tone controls or room correction.   The new Cambridge Audio EVO 150 also interests me.  Like you, my main interest in them is as a front-end feeding a big power amp.  Although, the M33 may have enough headroom for the 800s. 

 

Link to post
Share on other sites

I did consider the Hegel also , but as you mentioned no tone controls etc.

Aurender has some nice gear too. Ive seen a few videos with the M33 driving some good sized speakers.

Had my eye on the B&W 803 D3 for a while , one day maybe. As you said its a bit difficult to find a retailer who has gear in stock to demo.

What we need is a company who could arrange a demo in your own house for what ever brand or equipment Australia wide,

you pay a small fee for shipping/demo , and if you buy the product that fee is deducted from the sale price, just a thought.

 

Thanks

Link to post
Share on other sites


47 minutes ago, MusicForever said:

I've been trying to get a listen to the M10 and the M33.  None of the dealers in Brissie- that I have approached- has one to listen to.  (Trimira/ Audio Tailor etc...)   The Audio Tailor suggested the Hegel 190 but, as well regarded as they are, I have no interest in any device that doesn't have tone controls or room correction.   The new Cambridge Audio EVO 150 also interests me.  Like you, my main interest in them is as a front-end feeding a big power amp.  Although, the M33 may have enough headroom for the 800s. 

 

 

9D5E3EAF-B30F-4490-97F7-7B10057CE489.png

Link to post
Share on other sites

I already called Tristan.  (He owns Brissie HiFi and Trimira)  It's listed on their web page but is not actually in stock.  Same for Living Sound.   Considering your other idea, above, I've always had good service in the past from the high end dealers letting me borrow demo gear from their showrooms to try at home.   (Maybe if you own $45k speakers they cut you an extra  bit of slack.....)

Link to post
Share on other sites
1 hour ago, MusicForever said:

I've been trying to get a listen to the M10 and the M33.  None of the dealers in Brissie- that I have approached- has one to listen to.  (Trimira/ Audio Tailor etc...)   The Audio Tailor suggested the Hegel 190 but, as well regarded as they are, I have no interest in any device that doesn't have tone controls or room correction.   The new Cambridge Audio EVO 150 also interests me.  Like you, my main interest in them is as a front-end feeding a big power amp.  Although, the M33 may have enough headroom for the 800s. 

 

Lots of other gear to use as front ends without doubling up on power amps 

Link to post
Share on other sites
On 01/05/2021 at 8:10 PM, pcking said:

I haven’t got it running yet, gets halfway thru the update then 

goes to standby mode. Sent a requested to NAD for some help.

 

 

Paul,  Any news on the M33?

Link to post
Share on other sites
1 hour ago, pcking said:

Hi,no luck yet , will have to send back to get it looked at,

NAD sent thru an update but it didn't help ( oh the joys of Hi Fi )

 Talk later .

Cheers Paul.

Be prepared for a bit of a wait if it doesn’t take the software update - my C298 replacement took a while…….

Link to post
Share on other sites
On 17/03/2021 at 2:47 AM, Gav.H said:

Ordered my m33 early in the year, originally expecting it March but the store only received 1 amp and ordered 2nd. Now expecting the amp April. Intention is to pair with my new 804’s which did arrive.

Hi, did the M33 turn up yet? 
Cheers Paul

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...