Jump to content

JL Audio Fathom F212 Repair advice wanted


Recommended Posts

My JL Audio Fathom F212 has just started to hum. Even when the input balanced lead is removed.

Still makes music though when  the lead is plugged in but hums irrespective.. I am thinking something in the power supply is making it do a 50HZ hum.

 

As I am in Newcastle and it weighs 100kgs I dont wish to go far to get it fixed.

 

Any advice?

Link to post
Share on other sites
  • Administrators

In the first instance, have you tried plugging it into an alternative power point (preferably one on a different circuit)?

Link to post
Share on other sites

There is a guy in Perth that specializes in JL audio 

The hum issuse was quite common and I think there was some mods that were required 

I know that Perth is a long way away  but 

 

1   You could unscrew the plate amp and just send that 

2  Ring him and see if he has a contact in NSW that could help you 

 

RF Waves  08  93427161 

His name is Chamila 

 

He is an excellent Tech 

 

Cheers 

Link to post
Share on other sites


14 hours ago, shovel said:

My JL Audio Fathom F212 has just started to hum. Even when the input balanced lead is removed.

Still makes music though when  the lead is plugged in but hums irrespective.. I am thinking something in the power supply is making it do a 50HZ hum.

 

As I am in Newcastle and it weighs 100kgs I dont wish to go far to get it fixed.

 

Any advice?

The version 1 F113's have issues in the power supplies where some caps fail and the amps don't switch on.  There's a kit available to do the repair from JL but when I took my sub to the local authorised tech to get the repair done he said that they have their own kit with higher quality caps.  I suspect the repair for this issue is pretty easy as it was only abut $300.   The plate amp is the hard part to get out, you can't just undo the bolts and pull it out.   It needs to be pulled out with some oversize bolts.   Info is available on google or from JL on how to do this.   My second sub has a transformer type him which comes and goes, sounds like it's different to your 50hz hum though.   I took this sub to the same repairer for the cap upgrade as it was likely to fail hoping that this would sort the hum, didn't help that.

 

I've had some very good response from JL's tech Randy Wagner via email.   I'd maybe start with an email to Randy as it might be a common issue with JL.

  • Like 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...