Jump to content

Jhsg

Earth question.. BHK250 & REL subs.

Recommended Posts

If you tried the wireless kit and had no wire connection between the subwoofer and the amplifier, and your subwoofer hummed when the amplifier was off then are you sure that the subwoofer doesn't need repair?


Edit: the wireless kit power could be introducing a problem but there may be something wrong with the subwoofer plate amp

Edited by gwurb

Share this post


Link to post
Share on other sites
2 hours ago, gwurb said:

If you tried the wireless kit and had no wire connection between the subwoofer and the amplifier, and your subwoofer hummed when the amplifier was off then are you sure that the subwoofer doesn't need repair?


Edit: the wireless kit power could be introducing a problem but there may be something wrong with the subwoofer plate amp

No, its functioning fine and these symptoms are common with people using my setup - have a look at the link in the opening post of this thread. I have double checked this by wiring it up to another amp I have. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...