Jump to content

Sign in to follow this  
sir sanders zingmore

Strange Roon & Sonos network issue

Recommended Posts

Not sure if this is the right place but hopefully someone can assist.

 

I've recently had an odd issue appear with Roon and Sonos. I have my Roon server and my Sonos system setup on the same network and until recently, all devices could "see" both Roon and Sonos. In addition, my Sonos system showed up as a device in Roon

 

Suddenly I have the situation where on some devices I can access Roon but not Sonos. On other devices I can access Sonos but not Roon. And in all cases Sonos doesn't show up at all in Roon.

All devices are on the same network.

 

Any ideas?

Share this post


Link to post
Share on other sites

It is likely a network issue. Check network settings on Roon server & Sonos that they are using DHCP. If you are using fixed IP address, check sub net.

 

Also, check your router to see whether there are any recent changes. 

 

Lastly, try switching everything off including your router (DHCP server), start router first, then other devices.

Share this post


Link to post
Share on other sites
34 minutes ago, Snoopy8 said:

It is likely a network issue. Check network settings on Roon server & Sonos that they are using DHCP. If you are using fixed IP address, check sub net.

Do you know how to check settings on Roon server & sonos?

 

35 minutes ago, Snoopy8 said:

Also, check your router to see whether there are any recent changes. 

how do do I do this?

 

36 minutes ago, Snoopy8 said:

Lastly, try switching everything off including your router (DHCP server), start router first, then other devices.

will try this, does it matter which order I turn them on again? 

Share this post


Link to post
Share on other sites

If you do not know how to check Roon and Sonos, it is unlikely you have changed things.

 

In your router next to NBN box, do you know how to login to admin?  You need to use browser and enter an IP address such as 192.168.0.1. If this is too hard, then you will need to get someone who knows a little of network setup.

 

When restarting everything up, start router first,  sequence for everything else does not matter.

Share this post


Link to post
Share on other sites


3 hours ago, Snoopy8 said:

If you do not know how to check Roon and Sonos, it is unlikely you have changed things.

 

In your router next to NBN box, do you know how to login to admin?  You need to use browser and enter an IP address such as 192.168.0.1. If this is too hard, then you will need to get someone who knows a little of network setup.

 

When restarting everything up, start router first,  sequence for everything else does not matter.

So I restarted everything and it gets stranger...

prior to restart I had the following:

Android Tablet: Roon and Sonos working

iPhone:                Roon working, sonos not working

Macbook air:      Roon working, sonos not working

 

After restart

Android Tablet: Roon not working and Sonos working

iPhone:                Roon not working, sonos working

Macbook air:      Roon working, sonos not working

 

grrrr

Share this post


Link to post
Share on other sites

Suggest going into Roon and troubleshoot there first. I trialled Roon a while ago, so cannot guide you in detail. In setup, there should be a section on networking, screen shot that page.

Share this post


Link to post
Share on other sites

Also, did you restart tablet, iPhone, MacBook?

Share this post


Link to post
Share on other sites
1 hour ago, Snoopy8 said:

Suggest going into Roon and troubleshoot there first. I trialled Roon a while ago, so cannot guide you in detail. In setup, there should be a section on networking, screen shot that page.

So the only info I can get from within Roon itself is the IP address: this is xxx.xxx.1.20

My MacBook air (which can connect to Roon) is on xxx.xxx.1.5

 

My iPhone (which can't connect to Roon now) is on xxx.xxx.86.220

My android tablet (which can't connect to Roon) is on xxx.86.217

where the xxx.xxx is the same for all devices

 

Not sure if that's useful?

 

Also, yes I've rebooted everything multiple times

 

Share this post


Link to post
Share on other sites


16 minutes ago, sir sanders zingmore said:

Roon xxx.xxx.1.20

MacBook Air xxx.xxx.1.5

Both those devices are on the same network, hence the connection is working.

What is the gateway address (router) on both those devices?

What is the subnet mask on both those devices?

16 minutes ago, sir sanders zingmore said:

iPhone xxx.xxx.86.220

android tablet xxx.86.217

Both those devices are on the same network, but it isn't the same network as the two devices above. Hence they aren't talking.

What is the gateway address (router) on both those devices?

What is the subnet mask on both those devices?

Share this post


Link to post
Share on other sites
15 minutes ago, pwstereo said:

Both those devices are on the same network, hence the connection is working.

What is the gateway address (router) on both those devices?

What is the subnet mask on both those devices?

Macbook air: subnet mask: yyy.yyy.yyy.y, router xxx.xxx.1.1

Roon (or rather the machine that Roon is running on): subnet mask yyy.yyy.yyy.y, router xxx.xxx.1.1

 

18 minutes ago, pwstereo said:

Both those devices are on the same network, but it isn't the same network as the two devices above. Hence they aren't talking.

What is the gateway address (router) on both those devices?

What is the subnet mask on both those devices?

iPhone: subnet mask: yyy.yyy.yyy.y, router xxx.xxx.86.1

Android tablet: I have no idea where to find the info

 

(so subnet masks are the same for all devices where I can find the info) 

Share this post


Link to post
Share on other sites
Posted (edited)

OK, so a subnet mask of 255.255.255.0 is standard for a class C network,

this means that the first three octets are not part of the network, the last octet is the available network address space.

The issue is that your router is running on a xxx.xxx.1.xxx network, along with your Roon device and Macbook Air. They are all talking to each other just fine.

 

You need to figure out why the iPhone and tablet are on a different network, xxx.xxx.86.xxx

 

Have you accidentally connected them to your neighbours wi-fi?

Or are you running a Guest wi-fi network on your own router on a different IP range?

Can you disconnect both the mobile devices from the network ("forget this network" type option), then carefully add them back to the same wi-fi network as your other two devices?

 

 

 

 

Edited by pwstereo
Messed up sentence

Share this post


Link to post
Share on other sites
12 hours ago, pwstereo said:

OK, so a subnet mask of 255.255.255.0 is standard for a class C network,

this means that the first three octets are not part of the network, the last octet is the available network address space.

The issue is that your router is running on a xxx.xxx.1.xxx network, along with your Roon device and Macbook Air. They are all talking to each other just fine.

 

You need to figure out why the iPhone and tablet are on a different network, xxx.xxx.86.xxx

 

Have you accidentally connected them to your neighbours wi-fi?

Or are you running a Guest wi-fi network on your own router on a different IP range?

Can you disconnect both the mobile devices from the network ("forget this network" type option), then carefully add them back to the same wi-fi network as your other two devices?

 

 

 

 

Ok I think I’m starting to understand the problem (I’m coming from a very low base). Thanks all 👍
After “forgetting” the network and rejoining, my iPhone now has Roon again. Haven’t tried the android tablet yet. 

 

Every device is on the same network name but it seems that sometimes means they have a different number. I’m using one of those google mesh things so maybe it’s when they connect to a different point?

 

So my next problem is that Sonos seems to be on a different network to Roon. Any idea how to change its network? There is nowhere in the Sonos app that I can find with any kind of network information. 

Share this post


Link to post
Share on other sites


12 hours ago, pwstereo said:

OK, so a subnet mask of 255.255.255.0 is standard for a class C network,

this means that the first three octets are not part of the network, the last octet is the available network address space.

The issue is that your router is running on a xxx.xxx.1.xxx network, along with your Roon device and Macbook Air. They are all talking to each other just fine.

 

You need to figure out why the iPhone and tablet are on a different network, xxx.xxx.86.xxx

 

Have you accidentally connected them to your neighbours wi-fi?

Or are you running a Guest wi-fi network on your own router on a different IP range?

Can you disconnect both the mobile devices from the network ("forget this network" type option), then carefully add them back to the same wi-fi network as your other two devices?

 

 

 

 

Should Trev set static addresses as well for his devices? (sorry if you already suggested that using computer-talk :)

Share this post


Link to post
Share on other sites
45 minutes ago, Darren69 said:

Should Trev set static addresses as well for his devices? (sorry if you already suggested that using computer-talk :)

i'm not really sure what this means, but logging in to my laptop this morning my router is on xxx.xxx.86.1 and i've lost roon :(

 

 

Share this post


Link to post
Share on other sites

I'm beginning to think your Google Mesh setup isn't properly working as a mesh network. It sounds like it is presenting two different networks.

 

It's puzzling that your router would have changed address. Are you sure the Macbook Air isn't now connected to the other network?

 

I think it'd be easier if someone who understand IP networks would visit you and sort it out, it's a bit hard via messages like this. Your location is Australia, so I suppose we are all close to your place.

Share this post


Link to post
Share on other sites
22 minutes ago, sir sanders zingmore said:

i'm not really sure what this means, but logging in to my laptop this morning my router is on xxx.xxx.86.1 and i've lost roon :(

 

 

Can you log into the router? Or is that what you mean by the 86.1 address?

 

The router home page should show you what devices it is 'seeing' and what their IP addresses are. For me I type http://192.168.1.1/ into the address bar and I get into the router (if this works, save the address to your internet faves).

 

Whatever devices you can see, I would set static addresses for them and that will tidy that up. Hopefully the Nucleus will be amongst them. For me it is static addresses for ROON Nucleus, Synology NAS, the Squeezebox out in the shed, the laptop and so on. Laptop is wifi, the rest are ethernet as that remains the most reliable connection here at Che Daz.

 

I don't know what type of router you have and a Googly might help :) but for my Archer the way to assign static IP addresses for devices is under the 'Advanced' tab against 'Network' and then 'LAN settings' (local area network). There is an 'address reservation' table there, you can also name the devices if it isn't already done. At least then the router wont be looking anywhere for anything etc so that might help to start with, I only bang on about this because I don't know much about computers but others told me to do this when I had similar issues maybe six to twelve months ago and it worked. You would just copy-paste the current IP address and make that it's permanent address if that makes sense.

 

Ah I see I am covering ground that @Snoopy8 has already touched on.

 

You will be able to fix it if you are happy to have a play in the router page, I have no brains and I worked it out after a while :) 

 

ROON/Sonos- the ROON community will help, those guys and girls are excellent as a resource.

 

Yeah as Pete @pwstereo sez above, it is hard to do via electronic comms. Does any of the above help? If not do you know an IT geek? It is frustrating when such inexplicable things happen with pooter music.

Share this post


Link to post
Share on other sites


13 minutes ago, pwstereo said:

Are you sure the Macbook Air isn't now connected to the other network?

From my limited understanding, it seems that the google mesh is presenting two different IP networks (both called the same thing and with the same password etc). Sonos is on one of them and Roon on the other and various devices connect to the networks at random

 

Is there some way of forcing google mesh to show a single network? 

Share this post


Link to post
Share on other sites
Posted (edited)
12 minutes ago, sir sanders zingmore said:

...it seems that the google mesh is presenting two different IP networks...

Just looking at some tech notes about the Google Nest/Mesh setup.

 

"Requirements: What you need to use Google Wifi

In addition to at least one Google Wifi point and the Ethernet cable and power adapter that come with it, you need:

  • A modem. Google Wifi is a router, not a modem. Your primary Wifi point needs to be connected to a modem with an Ethernet cable (provided). Additional points are wireless; they only need to be connected to a power outlet (although they can be connected to each other via Ethernet, if you prefer).
          Note: If you have a modem + router combo from your internet service provider (ISP), you'll need to connect your primary Google Wifi point to that device. To ensure that all of your devices are connected to Google Wifi's network, we recommend that you either turn off your modem + router's Wi-Fi functionality or set your devices to "forget" your previous network.
  • Broadband connection to your ISP
  • A Google Account
  • The latest version of the Google Wifi app on Android or iOS."

So, I'm wondering if you've disabled the old wi-fi network that your original Internet wireless router was providing?

I suspect that's the source of your xxx.xxx.1.xxx network.

So get your laptop on the xxx.xxx.1.xxx network (plug a LAN cable into the laptop and a switch port on the router), open your web browser, put the router address into the address bar, most likely xxx.xxx.1.1 log in (often admin admin, or might be shown on a sticker on the device, or in the manual) and go to the wi-fi configuration and disable the wi-fi.

 

Then restart all your devices and connect to the remaining wi-fi network.

Check that they're all now on the xxx.xxx.86.x network.

 

Edit:  PS, I think you are better off avoiding static IP addressing if you can help it.

It's more maintenance and if you aren't keen on fiddling with networking it's a chore you don't need in most situations.

Edited by pwstereo
Added PS

Share this post


Link to post
Share on other sites
11 minutes ago, pwstereo said:

So, I'm wondering if you've disabled the old wi-fi network that your original Internet wireless router was providing?

I suspect that's the source of your xxx.xxx.1.xxx network.

So get your laptop on the xxx.xxx.1.xxx network (plug a LAN cable into the laptop and a switch port on the router), open your web browser, put the router address into the address bar, most likely xxx.xxx.1.1 log in (often admin admin, or might be shown on a sticker on the device, or in the manual) and go to the wi-fi configuration and disable the wi-fi.

 

Then restart all your devices and connect to the remaining wi-fi network.

Check that they're all now on the xxx.xxx.86.x network.

 

The original network is still active but it has a different address (xxx.xxx.0.4) and no devices are connected to that.

It really does look as if google mesh is presenting two addresses (xxx.xxx.86.x and xxx.xxx.1.xxx)

 

Share this post


Link to post
Share on other sites
15 minutes ago, sir sanders zingmore said:

The original network is still active but it has a different address (xxx.xxx.0.4) and no devices are connected to that.

It really does look as if google mesh is presenting two addresses (xxx.xxx.86.x and xxx.xxx.1.xxx)

Hmmm, that's weird.

Can you look at the config of the mesh/nest thing/s with either the Google Home app or the Google WiFi app?

Share this post


Link to post
Share on other sites

Do factory reset of Google Mesh and start again. Could kill wifi in house if things go wrong.

 

Strongly recommend getting someone to walk you through your network setup and take plenty of notes.  Unfortunately, networking is not plug and play.

Share this post


Link to post
Share on other sites
46 minutes ago, Snoopy8 said:

Do factory reset of Google Mesh and start again.

Agreed, clean slate and a known configuration.

Share this post


Link to post
Share on other sites

If we never hear from sir zingmore again, we'll know what happened  🤣

Share this post


Link to post
Share on other sites

I'm actually at work (from home) and can't afford to bring my network down right now

 

will try a bit later tonight

 

 

Share this post


Link to post
Share on other sites
On 19/06/2020 at 12:30 PM, Snoopy8 said:

Do factory reset of Google Mesh and start again. Could kill wifi in house if things go wrong.

 

Strongly recommend getting someone to walk you through your network setup and take plenty of notes.  Unfortunately, networking is not plug and play.

OK factory reset done and everything is working (for the moment)

 

Thanks to all for your very patient help. This is one of the reasons I love this community 😀😀

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...