Jump to content

p.laver

Pioneer 608 Plasma Failure

Recommended Posts

Hi, My beloved Pioneer 608 has decided to play up, first strange lines appeared on screen with a solid black line, see photos and after few minutes the screen went blank and the stand-by light blinking. The Stand by light blinks 'Red' 8 times and then pauses Then 8 times again etc

Anyone seen this before or know what type of failure this is?? is worth repairing???

Any feedback would be much appreciated.
 

Attachments

334CBF2A-0E2A-4B66-AD6C-4B860485DA8C.jpeg

70AEFCB6-71E1-40FE-B667-0B7F0864B8DA.jpeg

Share this post


Link to post
Share on other sites

I owned my Pioneer KPR-500M for 10 years and I am looking for an opportunity to replace it for a 4k panny oled.  If I were you I will get a new TV and move forward

Share this post


Link to post
Share on other sites

I think that is a power supply issue.

 

If you don't get it repaired, I would be interested in purchasing the side speakers.

Share this post


Link to post
Share on other sites


46 minutes ago, p.laver said:

Panasonic make excellent OLED's sadly they won't be here for much longer https://thenewdaily.com.au/life/tech/2020/02/05/panasonic-tv-australia-stops/ not sure living in Australia buying a Panasonic is a good idea

be good to know if fixing the kuro is an a prospect... if 100s dollars be cheaper than a new set. nope no oleds from panama's but there are ones from sony. I wouldn't look at anything else quite frankly....

 

3 hours ago, Midas said:

I owned my Pioneer KPR-500M for 10 years and I am looking for an opportunity to replace it for a 4k panny oled.  If I were you I will get a new TV and move forward

same telly here .... if mine dies it dies... 10 years onwards is a pretty good run with anything these days.... mine still looks fantastic but realise could go poop anytime :D  

Share this post


Link to post
Share on other sites
48 minutes ago, Telecine said:

I think that is a power supply issue.

 

If you don't get it repaired, I would be interested in purchasing the side speakers.

That’s what I’m hoping but the vertical black block is worrying, I’ve emailed both Australia and UK technical support to see if they can help and know what parts if any are still available. 
 

I will keep you in mind if I can’t get the screen repaired 

Share this post


Link to post
Share on other sites
12 minutes ago, betty boop said:

be good to know if fixing the kuro is an a prospect... if 100s dollars be cheaper than a new set. nope no oleds from panama's but there are ones from sony. I wouldn't look at anything else quite frankly....

 

same telly here .... if mine dies it dies... 10 years onwards is a pretty good run with anything these days.... mine still looks fantastic but realise could go poop anytime :D  

If I could get the penny flagship 65inch model I just might dig deep other than that I was thinking ‘LG’

Share this post


Link to post
Share on other sites
Posted (edited)
20 hours ago, betty boop said:

be good to know if fixing the kuro is an a prospect... if 100s dollars be cheaper than a new set. nope no oleds from panama's but there are ones from sony. I wouldn't look at anything else quite frankly....

 

same telly here .... if mine dies it dies... 10 years onwards is a pretty good run with anything these days.... mine still looks fantastic but realise could go poop anytime :D  

KRP 500M's don't appear to die!!!!!😄

Got mine in '09 and still see no reason to change.

Edited by JohnL

Share this post


Link to post
Share on other sites


BTW, does anyone know how to get into engineering mode for KPR 500M ? I was using it nearly non stop for the past 10 years,  I wanna check the cost to use it per hour ! Thanks 🙏

Share this post


Link to post
Share on other sites
2 hours ago, JohnL said:

KRP 500M's don't appear to die!!!!!😄

Got mine in '09 and still see no reason to change.

I've also got a 506 with separate media box I bought in England back in 2006, it's been sitting on a TV cabinet, not touched in 3 yrs, fired it up last night, picture is sill pin sharp.

 

It's  crying shame they killed off Plasma!!! I can only ever see one issue with Plasma, they're f'ing heavy!!!!

Share this post


Link to post
Share on other sites
1 hour ago, Midas said:

BTW, does anyone know how to get into engineering mode for KPR 500M ? I was using it nearly non stop for the past 10 years,  I wanna check the cost to use it per hour ! Thanks 🙏

You could try:

 

* Make sure the Plasma and the Media Box are in standby.

* Using the remote control:

* Press {DISPLAY} button (just press, do not hold) and wait 3 seconds.

* Press {LEFT} {UP} {LEFT} {RIGHT} {POWER} buttons.

* The Plasma will turn on with the "Information" page displayed.

* Press {MUTE} to move through the levels of menus:

 or

  • Start with the plasma in standby
  • Make sure you point the remote directly at the IR sensor in the tv
  • Press the info button on the remote (just press, do not hold)
  • Wait 3 seconds
  • Press LEFT, UP, LEFT, RIGHT then POWER
  • If done correctly, the plasma turns on and the INFORMATION page is displayed, will change 3 times on its own quickly.

Share this post


Link to post
Share on other sites
1 hour ago, p.laver said:

You could try:

 

* Make sure the Plasma and the Media Box are in standby.

* Using the remote control:

* Press {DISPLAY} button (just press, do not hold) and wait 3 seconds.

* Press {LEFT} {UP} {LEFT} {RIGHT} {POWER} buttons.

* The Plasma will turn on with the "Information" page displayed.

* Press {MUTE} to move through the levels of menus:

 or

  • Start with the plasma in standby
  • Make sure you point the remote directly at the IR sensor in the tv
  • Press the info button on the remote (just press, do not hold)
  • Wait 3 seconds
  • Press LEFT, UP, LEFT, RIGHT then POWER
  • If done correctly, the plasma turns on and the INFORMATION page is displayed, will change 3 times on its own quickly.

Thank you, but this one is for Pioneer Plasma and media box, NOT for the monitor version. I tried a few years ago,  it did not work.

Share this post


Link to post
Share on other sites


4 hours ago, p.laver said:

I've also got a 506 with separate media box I bought in England back in 2006, it's been sitting on a TV cabinet, not touched in 3 yrs, fired it up last night, picture is sill pin sharp.

 

It's  crying shame they killed off Plasma!!! I can only ever see one issue with Plasma, they're f'ing heavy!!!!

And pump out some heat!!!!............

Share this post


Link to post
Share on other sites
On 04/05/2020 at 8:51 PM, Telecine said:

I think that is a power supply issue.

 

If you don't get it repaired, I would be interested in purchasing the side speakers.

I've just sent you PM, ref the speakers.

 

Just got off the phone with a company in Melbourne they don't think it's a panel issue, just need to arrange time etc for them to come out and look at the panel.

Share this post


Link to post
Share on other sites
10 hours ago, Jamie123 said:

End up getting it fixed?

I'm still waiting for the company carrying out the inspection to get back to me with quote as there appears to be an issue with correctly identifying the failed part with Pioneer. 

 

 

Bad news, I received a phone and was informed the panel needs to be replaced and they can't source one. Shame I have to admit I do have soft spot for Pioneer Plasma's 

 

I'll fire up my older 506 tomorrow, I bought this one over UK and has been sitting on a stand for the 3 years and not used.

Edited by p.laver

Share this post


Link to post
Share on other sites


Hello

 

i own several kuros including the 508 and 500m

 

given they have about 1000 lines of motion resolution , and given OLED has about 300 lines of motion resolution you may be let down by what OLED offers IF you are just watching Blu ray movies.  Even for UHD 4k whilst the movie is encoded at 3840x 2160 , once the picture moves you will not see all that resolution

 

the kuros were well built and if you ring pioneer Melbourne they will give you names of authorised service agent

 

sometimes a repair isn’t expensive . If it were me I would take a 608 over an oled . Once you see banding and vignetting on an oled, and tinting when watching black and white movies, you will be pissed off

 

i love the vibrant colours OLED and its perfect blacks . But even after all these years , once the action on the screen starts moving, it can’t resolve the resolution encoded on the disc . 
 

Apparently according to Vincent , the new HZ series OLED from Panasonic allows a native 120 hz BFI option that jacks up the motion to around 900 lines of motion resolution ( still not 2160 lines ). And unlike LG’s BFI option , with Panasonic you are not tied to the other motion interpolation algorithms when selecting BFI
 

but the hz is available in New Zealand from Harvey Norman 

 

the GZ can’t do 120 hz BFI

Share this post


Link to post
Share on other sites
42 minutes ago, Kdjjdk Will said:

Hello

 

i own several kuros including the 508 and 500m

 

given they have about 1000 lines of motion resolution , and given OLED has about 300 lines of motion resolution you may be let down by what OLED offers IF you are just watching Blu ray movies.  Even for UHD 4k whilst the movie is encoded at 3840x 2160 , once the picture moves you will not see all that resolution

 

the kuros were well built and if you ring pioneer Melbourne they will give you names of authorised service agent

 

sometimes a repair isn’t expensive . If it were me I would take a 608 over an oled . Once you see banding and vignetting on an oled, and tinting when watching black and white movies, you will be pissed off

 

i love the vibrant colours OLED and its perfect blacks . But even after all these years , once the action on the screen starts moving, it can’t resolve the resolution encoded on the disc . 
 

Apparently according to Vincent , the new HZ series OLED from Panasonic allows a native 120 hz BFI option that jacks up the motion to around 900 lines of motion resolution ( still not 2160 lines ). And unlike LG’s BFI option , with Panasonic you are not tied to the other motion interpolation algorithms when selecting BFI
 

but the hz is available in New Zealand from Harvey Norman 

 

the GZ can’t do 120 hz BFI

hi Will, i really appreciate this post.... and its a good point you make... and probably why I still so enjoy our pioneer 500M last of breed. thanks re the tip about pioneer melbourne too. if mine ever went on the blink i definitely will give them a call re the authorised service agent(great to hear still supported). its not my main display as have a projector, so dont necessarily need to spend 1000s to replace with an oled in any case. we are very happy with our 500M for most things when comes to every day tv....

Share this post


Link to post
Share on other sites

As you know Al with the 500m you can go into the service menu and adjust the voltages to give you oled level blacks 

 

I did this over a year ago and people weep when they see my 500m 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...