Jump to content

xis

Velodyne SPL-1200 Ultra - Strange Problem

Recommended Posts

My beloved Velodyne SPL-1200 Ultra has stopped outputting sound. What I find strange is the way in which it stopped. One morning I received a small static shock whilst turning it on from the front panel standby button. I didn't think much of it as the sub powered up and worked fine for several hours. It wasn't until attempting to turn it back to standby I noticed the button no longer functioned. Figuring the shock upset something, I instead used the power switch on the back plate to turn it off. When I next went to use the sub, the standby button didn't do anything. I grabbed the remote which seemed to turn it on (LED display lit up), however there's now no output. The fact that it worked fine until restarted feels like a hint at what may be broken. If it helps I do recall that previously I might have had to press the standby button a couple times for it to power on (maybe dodgy button, or power supply related?).

 

So far, to no effect, I've checked the fuses in the rear power plug, left it off and unplugged for several hours, and performed a factory reset via the remote. I also had a quick look at the plate amp hoping for a blown internal fuse but couldn't easily see something like that.

 

Any ideas at what may be wrong? Is there anything else I can check? Failing that, any recommendations on a repairer would be appreciated.

Share this post


Link to post
Share on other sites

 

is there a fuse ? check another outlet. another power lead.... otherwise likely something has gone kaput, id check the thread above for repairers.... there are couple of other threads too if search this sub forum for velodyne. check with the importer though. velodyne has new owners in Germany who are cling on line, seem quite committed though understand they are still in the throngs of getting organised. so not sure response will get.

Share this post


Link to post
Share on other sites

How old is it? It might have a dry capacitor somewhere.

Share this post


Link to post
Share on other sites

  Just been through this excercise a few months ago -  probable cause is a series of small capacitors changing ESR values . Normally an easy repair if they were not buried inside a metal cage that is soldered onto a double sided  pc board . Labour costs is the killer 

Take it to a good tech to get a quote - could be something simple ?.

You can order another plate amplifier from the importer approx $600 .

They have no stock at the moment due to Velodyne being recently sold to a German group. ETA  was May .Could be longer with COVID

The SPL series are excellent subs and worth repairing .

Wish I still had mine .☹

Share this post


Link to post
Share on other sites


1 hour ago, betty boop said:

is there a fuse ? check another outlet. another power lead.... otherwise likely something has gone kaput,

There are fuses in the power socket. Both looked fine and I confirmed they were good with a multi-meter. It does get some power as it lights up the front LED panel - just no output.

57 minutes ago, myhifiacct said:

How old is it? It might have a dry capacitor somewhere.

It's a little over six years old so not new but not ancient either.

18 minutes ago, mavi said:

Take it to a good tech to get a quote - could be something simple ?.

You can order another plate amplifier from the importer approx $600 .

They have no stock at the moment due to Velodyne being recently sold to a German group. ETA  was May .Could be longer with COVID

The SPL series are excellent subs and worth repairing .

Wish I still had mine .☹

I'll have to search for a good repairer. I'm in Adelaide so guessingit may need to go interstate.  Silly question but who is the Australian importer? Since Velodyne ditched audio their site just refers to an Australian geospatial company 😄 Be nice to get a quote from them as if the repair and replace costs aren't much different I know what I'd prefer!

 

What path did you end up taking with your sub?

 

And definitely agree about these SPL subs - they sound amazing! I'd love to keep it going.

Share this post


Link to post
Share on other sites
4 minutes ago, xis said:

I'll have to search for a good repairer. I'm in Adelaide so guessingit may need to go interstate.  Silly question but who is the Australian importer? Since Velodyne ditched audio their site just refers to an Australian geospatial company 😄 Be nice to get a quote from them as if the repair and replace costs aren't much different I know what I'd prefer!

https://www.velodyneacoustics.com

 

https://www.velodyneacoustics.com/service/

 

audio reference in germany, might have to contact them on who local importer here is, but as i said its was only very late last year and given the turmoil world has been in since i doubt its the priority right now ! 

 

in repairers locally here as per thread I linked to there are quite a few. close to me JLS electronics repair. but possible someone in SA or someone else you want to send to, check the thread I linked to earlier and also there velodyne threads in this subform which will find if search for Velodyne and "this sub forum :) 

Share this post


Link to post
Share on other sites

agent is Revolution Technologies spares@revtek.com.au

Service manager  - Aaron Misso   aaron@revtek.com.au

I still have mine but had a spare REL R305 that I am currently using

Will chase it up at a latter date

Hope this helps

Cheers 

Share this post


Link to post
Share on other sites

Appreciate the info betty and mavi.

Share this post


Link to post
Share on other sites


Let us know what the repair quotes are, I'd be interested to know since I own a few Velodyne subwoofers myself.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...