Jump to content

Recommended Posts

Thanks for your help on this - new to stereo.net. Have just started my fist system with Rotel 1592 amp + Dynaudio evoke 20 speakers. 

 

Question is - streaming from Tidal on my Mac via USB to Rotel internal DAC - The amp clicks every time i change song, even just sometimes randomly. 

 

It's a really annoying sound. Didn't happen during the demo. And doesn't happen when connected to a Windows PC.

 

Has anyone else faced this and how did you solve it?

 

Thanks very much

 

Andy

Share this post


Link to post
Share on other sites

Is this just with the Mac or is this also with other sources.

I would also try it with a TV using optical to narrow down if it happens with multiple sources.

Share this post


Link to post
Share on other sites

With all sources including Bluetooth and tv, anything that uses the Rotel internal dac

Share this post


Link to post
Share on other sites
Posted (edited)

Is the unit still under warranty? If so I would have this looked at. 

If it was used, I would ask the user to at the least, help cover the repair. 

 

If it was just the sub playing up, it could have been the Mac. With all digital inputs causing the issue, then it seems like a fault.

Edited by Mungbean66

Share this post


Link to post
Share on other sites


I don't believe it's a fault, but i would assume that Rotel are using a relay based DAC, this "clicks" when it locks onto the digital signal.

 

My old Vincent CD-S7 DAC was the same.

 

 

Share this post


Link to post
Share on other sites
27 minutes ago, thathifiguy said:

I don't believe it's a fault, but i would assume that Rotel are using a relay based DAC, this "clicks" when it locks onto the digital signal.

 

My old Vincent CD-S7 DAC was the same.

 

 

Maybe, I've never seen anything like this personally. Not to mention it would be a poor design using a relay which will fail quickly if switching all the time.

In saying that I believe designs like this would exist but in a new intergrated, you'd hope not.

 

It's probably best the OP contact Rotel directly to see if this is the case.

Share this post


Link to post
Share on other sites

Thanks very much for your help. Returned it to the store and have got the demo model which worked well instead! Thanks 

Share this post


Link to post
Share on other sites

Thanks for the update Andrew. Happy you got it sorted.

The constant clicking would have sent me mad.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...