Jump to content

Sign in to follow this  
wen

STATIC PROBLEM REGA PLANAR 2

Recommended Posts

I have an old Rega Planar 2, slate with a silicone barrier added to plinth, squash balls for feet, fitted a moth oem202 arm with an ortofon quintet blue MC cartridge, has a project cork mat. I purchased and fitted a Tangospinner subplatter, never had an issue with static, but with the Tangospinner the cork mat lifted off with the record, usually change records with the platter spinning, when i went to take the cork mat off record you could hear the crackling of static, i tried a new anti-static brush, but no change. The wiring for the Moth arm has no seperate earth, so i made up a lead and connected it to my NAD PP2e earth tap and the other end left bare, spread the strands, obtained a nut to fit over the bearing housing thread under the turntable, this was a loose fit, managed to get the wire between the nut and thread, could only tighten the nut so far, no more issues with static

15773614240651665204708.jpg

20191226_192614.jpg

1577361373416711470668.jpg

Edited by wen

Share this post


Link to post
Share on other sites

Try this (it works for me) if you get any further issues:

 

On your last pass of the brush, go slowly out to in, trailing off over the centre pin.

 

 

Edited by furtherpale

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...