Jump to content

Sign in to follow this  
Wood

C9 and FTA Channels

Recommended Posts

Recently upgraded TV to LG 55” C9. 
Very happy with performance watching Netflix etc via Apple TV 4K and Foxtel HD - mainly Fox Sports channels. 
 

However, regular channels like 7, 9 & 10 (even the HD ones) are a pixelated mess. 
The AFL GF was unwatchable and I ended up streaming the NRL GF from my phone to the Apple TV. 

 

I tried bypassing the Foxtel box by connecting the tv directly to the antenna wall plate. Same issue. 
 

What gives?

Share this post


Link to post
Share on other sites

Now I'm no expert on this other guys on here will be more knowledgable but it sounds like the networks aren't devoting enough band width to these channels.

Share this post


Link to post
Share on other sites

Surely not everyone in Australia with a C9 is having the same issue?

Share this post


Link to post
Share on other sites
1 hour ago, Wood said:

The AFL GF was unwatchable

I believe this was on the main SD channel due to siphoning laws. We watched on Kayo in HD but still some cameras looked pretty average.

 

I'd suggest your signal might be borderline, perhaps the C9 doesn't have as good a tuner as your previous TV

 

I have a old Samsung 55" and FTA HD is fine, but I sit about 4m from the screen in my living room. We have a HT room when we want that big screen effect

 

Edited by blybo

Share this post


Link to post
Share on other sites


24 minutes ago, blybo said:

I believe this was on the main SD channel due to siphoning laws. We watched on Kayo in HD but still some cameras looked pretty average.

 

I'd suggest your signal might be borderline, perhaps the C9 doesn't have as good a tuner as your previous TV


It looked the same whether I used the FTA antenna direct to TV or Foxtel IQ3 to TV. 

Share this post


Link to post
Share on other sites

so perhaps tuner/processor of the TV not liking average bitrate signal.

Share this post


Link to post
Share on other sites

Get a Foxtel IQ4 STB and problem solved.

The onboard FTA HD MPEG4 tuner is great.

Also....... Foxtel now has 3 dedicated 4K channels.........which your LG C9 will love.

Edited by JohnL

Share this post


Link to post
Share on other sites

Got a C9 and no issues with FTA, picture is excellent, my FTA source is currently from Fetch TV into a Yamaha av receiver, I have also used Foxtel FTA and all good.

Share this post


Link to post
Share on other sites


56 minutes ago, JohnL said:

Get a Foxtel IQ4 STB and problem solved.

The onboard FTA HD MPEG4 tuner is great.

Also....... Foxtel now has 3 dedicated 4K channels.........which your LG C9 will love.

IQ4 only available with satellite connection. I’m currently on cable. But that’s good to know!

Share this post


Link to post
Share on other sites
49 minutes ago, awayward said:

Got a C9 and no issues with FTA, picture is excellent, my FTA source is currently from Fetch TV into a Yamaha av receiver, I have also used Foxtel FTA and all good.


Interesting. So possible issue with my unit...?

Share this post


Link to post
Share on other sites
14 minutes ago, Wood said:


Interesting. So possible issue with my unit...?

I just remembered that I to have had some issues with FTA, mainly with dropouts due to a week signal, I bought a signal amplifier from Jaycar, all good since, it might be worth a try.

Share this post


Link to post
Share on other sites
11 minutes ago, awayward said:

I just remembered that I to have had some issues with FTA, mainly with dropouts due to a week signal, I bought a signal amplifier from Jaycar, all good since, it might be worth a try.

Worked perfectly fine with previous UHD LED TV. 

Share this post


Link to post
Share on other sites


2 minutes ago, Wood said:

Worked perfectly fine with previous UHD LED TV. 

My signal was fine with IQ3, not strong enough with IQ4.

Share this post


Link to post
Share on other sites

I have a C8 and will probably buy next years 77’ c series. I don’t have a problem with FTA channels, especially the HD channels.

 

it could actually b as simple as your coaxial cable may have been damaged or your tv antenna has been somehow damaged/degraded.

 

i would try a different coax cable in the first instance. If you have a different tv that works fine with that coax, I would say it’s a problem with the c9’s tuner.

Edited by Ray H

Share this post


Link to post
Share on other sites
1 minute ago, Ray H said:

I have a C8 and will probably buy next years 77’ c series. I don’t have a problem with FTA channels, especially the HD channels.

 

it could actually b as simple as your coaxial cable may have been damaged or your tv antenna has been somehow damaged/degraded.

 

i would try a different coax cable in the first instance. If you have a different tv that works fine with that coax, I would say it’s a problem with the c9’s tuner.


Appreciate the thoughtful reply. Thing is, it’s the same issue whether using the FTA aerial on my roof or via Foxtel IQ3 box...

 

And it’s only since upgrading to the C9 a few months back. 

Share this post


Link to post
Share on other sites

Eagerly awaiting the arrival of my 65" C9 now with a bit of nervousness after reading this post.

Once I'm up and running I'll report back with my experience and any issues with pixillation as described by WOOD.

Fingers crossed 😒

Share this post


Link to post
Share on other sites


On 21/11/2019 at 12:16 PM, bricyn said:

Eagerly awaiting the arrival of my 65" C9 now with a bit of nervousness after reading this post.

Once I'm up and running I'll report back with my experience and any issues with pixillation as described by WOOD.

Fingers crossed 😒

How did you go?

Share this post


Link to post
Share on other sites

OK, C9 update.

Firstly, terrestrial channels that I have tried all check out ok (i.e. picture is fine,,,,, programs still rubbish though!!)

The one issue I have is pixellation on Netflix. I have Foxtel and watch Netflix on IQ4 box and that is fine. I have a reasonable NBN speed >32 Mbps tested on the tv using SPEEDTEST. so presumably internet speed is not or should not be the the problem. So, I would guess, and I'm no expert but have experienced pixillation in the past the issue with FTA, the problem is probably the antenna or any connections between that and the tv but this 

Netflix issue is perplexing and if anyone here has any suggestions for a remedy that would be really welcome 'cause if I do away with Foxtel in the future I'm stuck with a very poor picture using the Netflix app.

BTW, TV and Netflix have all the updates done.

Share this post


Link to post
Share on other sites

Interesting about Netflix. I only use an ATV4k for streaming. 
I did try apps on the TV when I first got it (before I upgraded to the 4K ATV) and found the experience underwhelming. To be honest I don’t remember if it was picture quality or user experience or a combination of both. I’ve now had the ATV4k for a while and am really happy with the user experience and picture quality. 
Every now and then it’ll pixelate but It’s rare and I’m assuming it’s due to traffic on the network in my area. It quickly corrects itself. I have NBN50. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...