Jump to content

Sign in to follow this  
Jason k

Epson eh tw8200

Recommended Posts

Hi all,I have a Epson eh tw8200 projector,brought refurbished from Epson on there display units,had it since 2015 with under 300hrs on globe,just recently a green shadow has appeared during start up but once the black screen turns to the picture the problem goes and picture perfect,anyone else experience this same problem?

Share this post


Link to post
Share on other sites
On 11/11/2019 at 6:16 PM, Jason k said:

Hi all,I have a Epson eh tw8200 projector,brought refurbished from Epson on there display units,had it since 2015 with under 300hrs on globe,just recently a green shadow has appeared during start up but once the black screen turns to the picture the problem goes and picture perfect,anyone else experience this same problem?

Have you noticed the same green tinge of shadow on a black field? like end credits? If so it could be dust on the lcd panels which is a cheaper service to fix over more serious issues. But it could be something more to do with the optical block or something else entirely. Hard to know but check black field end credits and see if still there first.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...