Jump to content

Sign in to follow this  
TrainShedMan

Onkyo TX-NR686 will not pass STB sound when HDMI out is to projector

Recommended Posts

I recently upgraded the home theatre with an Epson TW9400, Onkyo TX-NR686 and Panasonic DP-UB820GNK UHD bluray player. Mostly trouble free installation except for one thing. I have a HD STB connected to the Onkyo to watch big event stuff on the projector. The picture comes through wonderfully, but no sound. However, if I unplug the HDMI out from the Onkyo to the Epson, and instead connect it to the HDMI in ports on a UHD tv, I get picture and sound. Replug the projector, no sound again. From the menus on both the Onkyo and the STB, it appears to be set right - hence pic and sound to the tv - but nothing to the projector. Has anybody had this problem? Or can suggest a possible response? TIA. Steve.

Share this post


Link to post
Share on other sites

Sounds like a HDCP handshake error.

 

First thing to do is make sure you have the latest firmware for the Onkyo and Epson.

 

If that doesn't help, try changing the start-up order for the STB, Onkyo and Epson. In particular, try starting the Epson last and the Onkyo last.

 

If that doesn't help go through the same process, but with the TV turned off at the wall (many TVs will keep HDMI ports powered in standby and may confuse the HDCP handshake process).

 

Beyond this, probably need to call Ambertech - the local Onkyo distributor and ask for help.

Share this post


Link to post
Share on other sites

from my use of pjs always start the pj last in the start up sequence.

Share this post


Link to post
Share on other sites

I had exactly the same problem when I replaced my Yamaha 2071 receiver with Yamaha 3085. Have a JVC x7000 and Panasonic ub900, STB worked fine with the 2071 but no sound with the 3085, tried all sorts of things and couldn’t get it to work with hdmi. Ended up using digital coaxial output from the STB to the 3085 for the sound and the hdmi for picture. The coaxial cable is fine for Dolby Digital the STB puts out.

Share this post


Link to post
Share on other sites


Thanks all. I spoke to Onkyo support, they agreed using the optical input on the receiver was the best option. Pity my STB doesn't have an optical out, just HDMI, but Jaycar have an interface box that can strip the audio component from the HDMI signal and send it out via Toslink. I already use one in the lounge room for my AppleTV box. Now, to plan a quick trip to Jaycar ...

 

Steve

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...