Jump to content

Sign in to follow this  
Kensell21

Apple TV 4K Dolby vision green tinge

Recommended Posts

Ok I’ve finally got my tv, a 65” Sony X90f mounted on the wall cabled with good quality 4K hdmi cable to a Denon avr x4400.

Plugged in the Apple TV and 4K was detected and asked to change to 4K Dolby vision.

Unfortunately the tv shows a green tinge .. the A.V. has beeen set to do no processing.. what have I done wrong???

I have it set to the hdmi input 1 in the TV. Would that make a difference?

Current setting is 1080p Dolby vision which is fine.

 

c9fa170316de51c973bea408325a813a.jpg&key=1c05a75ec3f835fbdaaa05a394d4e0b1ad7bbf6d9787ccc5bff4999aca40ec3d

 

 

Share this post


Link to post
Share on other sites

It will be either a colour space mismatch in settings or a faulty HDMI cable. Start with the Apple TV's cable test.

Share this post


Link to post
Share on other sites

1080p is HD, not UHD 4K, Dolby Vision is a UHD 4K setting. There is something wrong with the settings on the TV.

Share this post


Link to post
Share on other sites

Ok I’ve had a bit of time to look at the settings on the Apple TV for a start. This is what my current settings are.

c50db22722c574a5b34b21230e7dcfdd.jpg

I’ve changed zone chroma to 4:4:4 which the TV accepts fine.
But ATM the best format I can get is 4K SDR without the picture going green.. I’ve a bit of a novice regarding the TV settings and I can’t see anything even in the advance settings to help with Dolby Vision. So if there’s anybody else out there who has this TV that can help??

Share this post


Link to post
Share on other sites


So did you run the cable test using Check HDMI connection?

Share this post


Link to post
Share on other sites

Yes the test runs fine. Also accepts the 4:4:4 which needs high speed cable.

Share this post


Link to post
Share on other sites

OK, have you tried HDMI input 2 or 3 on the TV?

 

Also, go into Match Content on the Apple and:

  1. Set Match Dynamic Range to On
  2. Set Match Frame Rate to On

 

 

Share this post


Link to post
Share on other sites

Yippee changing to input 2 makes it work. Great thanks my friend.
Hmm now do I change my Netflix to 4K??

Share this post


Link to post
Share on other sites


2 minutes ago, Kensell21 said:

Yippee changing to input 2 makes it work. Great thanks my friend.
Hmm now do I change my Netflix to 4K??

Good to hear you got it working.

 

You should still make the changes to the Apple TV suggested above.

 

See if a restart of the Apple, Sony and Denon sort out 4K Netflix, otherwise you may need to go into the settings on the Netflix app (presuming you've signed up for the right Netflix plan).

Share this post


Link to post
Share on other sites

So I should still keep matched content on???

Currently only on the high def plan with Netflix..
happy to look at changing.
I assume by just upgrading my plan, it’ll pick up automatically 4K and Dolby vision??

Share this post


Link to post
Share on other sites
6 minutes ago, Kensell21 said:

So I should still keep matched content on???

Currently only on the high def plan with Netflix..
happy to look at changing.
I assume by just upgrading my plan, it’ll pick up automatically 4K and Dolby vision??

Yes, keep both the matched content settings on. Then you'll get HDR when the content has it and SDR when not (SDR displayed as HDR will not be pretty). You'll also get frame rates matched and avoid the weirdness that happens when they're not.

 

Not sure whether a restart will sort out Netflix or whether you'll need to go into settings.

Share this post


Link to post
Share on other sites

Currently on the high def plan, Dolby vision pops up in the right hand corner so it seems as though it’s all ok..
just now to consider going to the 4K plan which is the next one up?? Not sure what the other streamers do... I have Amazon and Stan.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...