Jump to content

alessiman

Benq W2700 / W5700

Recommended Posts

3 hours ago, minireza said:

@Matt_Walker A question Regarding the Benq W5700; does the unit have any inbuilt Anamorphic modes?

 

I have a Prismasonic Anamorphic Lens, and if it woks with the Benq, it looking like a pretty hard projector to beat in terms of value for money!

 

I live near the Instyle store, so will be hopefully checking out the unit later today.

 

Cheers

Hey Minireza,

 

Not yet - but the good news is twofold.

 

These new models have the ability to firmware upgrade via USB (for the first time!!)  and we have a F/W update coming very shortly that will include anamorphic / cinemascope modes :)

 

It will definitely work with your leans and you are right - there is nothing that even comes close!

 

Say hello to Mario for me - that new store is awesome - cant wait to go back soon.

 

 

Share this post


Link to post
Share on other sites
22 minutes ago, Matt_Walker said:

Hey Minireza,

 

Not yet - but the good news is twofold.

 

These new models have the ability to firmware upgrade via USB (for the first time!!)  and we have a F/W update coming very shortly that will include anamorphic / cinemascope modes :)

 

It will definitely work with your leans and you are right - there is nothing that even comes close!

 

Say hello to Mario for me - that new store is awesome - cant wait to go back soon.

 

 

That's excellent news; any chance of an indicative timeline for the updated firmware?

Edited by minireza
spelling

Share this post


Link to post
Share on other sites
51 minutes ago, minireza said:

That's excellent news; any chance of an indicative timeline for the updated firmware?

Yes - but nothing that I am allowed to share just yet - the best i can offer is "coming soon" I am sorry. :)

 

Let's just say it will not be long ... (he says whilst trying not to sound like a "salesman")

Share this post


Link to post
Share on other sites

Hi all,

 

BenQ W2700 and W5700 True 4K projectors.

 

From tomorrow you will be able to see these 2 BenQ projectors on display with the team at Carlton Audio Visual in Melbourne and do some real world / side by side comparisons.

 

Go and see Rab, Paul and the team LIKE.png(y) they have a small allocation of stock available ready to go...

 

57000739_10216745588885464_7606969770839113728_n.jpg?_nc_cat=110&_nc_ht=scontent.fmel7-1.fna&oh=f18b0b38f09ef7940a44fe50dd1b498a&oe=5D3A9E64

Share this post


Link to post
Share on other sites


Don't take my word for it - :)
 
BenQ HT3550 / W2700 best by far!
 
 
"With the Vivitek, ViewSonic, and Optoma failing to stand out in any significant way, the buying decision narrows to the $1,800 Epson 4010 (TW8400) and the $1,500 BenQ HT3550. (W2700)"
 

Share this post


Link to post
Share on other sites

Well I love my new W5700, however I've struck a rather unusual issue with mine.

 

HDMI sync

 

I've got a Beyonwiz T4 (and U4 as well), and even running a 4k hdmi cable between it and my Pioneer SC-LX81 amp, I've regulary struck the issue of either the projector getting 1080 sync and black screen, or no sync whatsoever.

 

I have no apparently issues running my old Foxtel iq3 box and my old Oppo BD player through the amp, although sync appears to be taking longer than my old 'zebra' W5000.

 

If I bypass the amp, and run hdmi straight from the T4 to the projector, there's no issues at all.

 

 

Share this post


Link to post
Share on other sites

Interesting ... what cable are you running and what lengths?

 

Hdmi is a fickle beast sometimes :(

Share this post


Link to post
Share on other sites

T4 to amp is the 1m long 4k one that came with my new iq4 (they upgraded me from iq3 to iq4 for free).

 

The rest of the hdmi are a mixture of different brands, all of which I have swapped around the different devices to see if I had a dud one plugged in somewhere, mostly EzyHD ones I bought years ago

 

Share this post


Link to post
Share on other sites


Is the firmware up to date in the T4, projector and AVR?

Edited by Quark

Share this post


Link to post
Share on other sites
1 minute ago, Quark said:

Is the firmware up to date in the T4, projector and AVR?

 

 

T4 firmware up to day

W5700 current firmware it came with, as haven't heard of anything new.

SC-LX81 firmware is probably pretty ancient, i.e. never upgraded, so I'll go take a look and see if any available and how do upgrade it.

 

 

Share this post


Link to post
Share on other sites

I bet the Pioneer SC-LX81 is old and won't pass through 4k signal if that is what you want to achieve.  

Share this post


Link to post
Share on other sites
1 minute ago, PKK said:

I bet the Pioneer SC-LX81 is old and won't pass through 4k signal if that is what you want to achieve.  

Quite likely the case, but I'm only trying to pass through a 1080i/1080p signal at the moment (the T4 is not 4k)

 

It's quite an old amp, and got around the same time as my W5000, so good decade old.

 

Share this post


Link to post
Share on other sites


My setup is Chromecast > 5yo avr > 10m HDMI cable > w5700, no issues with 1080p. Will try to get it setup for 4K next couple of weeks.
Only compliant so far is the DI in dark scenes, too obvious and can't make up its mind, hope firmware update will improve it. Been watching GOT from S1 since I got the BenQ.

Share this post


Link to post
Share on other sites

My brother is law is currently in melbourne for a couple of days, where can we buy BenQ W2700 from ? I have asked him to visit Carlton Audio Visual is there any other retailers stocking this model

Share this post


Link to post
Share on other sites
51 minutes ago, enfield1212 said:

My brother is law is currently in melbourne for a couple of days, where can we buy BenQ W2700 from ? I have asked him to visit Carlton Audio Visual is there any other retailers stocking this model

Yep big picture people fountain gate if he wants to see it as well (carlton have a demo too!

Share this post


Link to post
Share on other sites
6 hours ago, bpratt said:

Quite likely the case, but I'm only trying to pass through a 1080i/1080p signal at the moment (the T4 is not 4k)

 

It's quite an old amp, and got around the same time as my W5000, so good decade old.

Yes from what I can see its before hdmi 1.3 vintage so is not compatible with things like 3d frame packed video your projector can handle for instance . My U4 likely has a hdmi 1.4 or better chipset as it can handle H265.   Everythings supposed to be compatible with hdmi2.0/hdcp2.2 but this is why manufacturers like Emotiva and even a Trinnov 16 are giving a 1.4/2.0 option in their pre pro's recently..

 

Quote

Four HDMI inputs and one of the outputs support HDMI 2.0 and HDCP 2.2, the others being HDMI 1.4 to ensure compatibility, but cleverly a forthcoming update will allow you to choose any combination of 1.4 and 2.0.

Its no surprise really when you see hdmi 2.1 features like E-ARC being incorporated into hdmi 2.0 that have regular ARC which is dependent on CEC control  imho ;) 

Share this post


Link to post
Share on other sites


thanks CWT for the info.

 

Sounds like I'm going to have to do it the dodgy way (connecting the T4 directly to the projector with optical audio out) till funds allow me to upgrade the old amp. At least having my Emotiva XPA amps, I won't need to buy such a powerful receiver, as long as it has outputs to utilise it.

 

No doubt Atmos will then be on the cards for me. :)

 

 

Can't find a firmware update for my SC-LX81 , as it appears Pioneer don't like to make them available to the public.

 

Share this post


Link to post
Share on other sites

A review of the ht5550/w5700.

Share this post


Link to post
Share on other sites

It will be interesting to see the results of the shoot out between the BenQ w5700 and the Epson 9400, when he does it.

Share this post


Link to post
Share on other sites

I have always enjoyed the sharpness of the Benq DLP's 😉

Photo taken with my Samsung S8+

 

Received my W5700 the other day

 

W5700.thumb.jpg.4013d0825e310acbc979d14e8720d749.jpg

Edited by jmos1503559753

Share this post


Link to post
Share on other sites

Anyone with a W5700 experiencing odd noises when dynamic iris (DI) is on? Almost like a soft grinding/rattling sound.

 

This is happening on my W5700, and also to a few owners on AVSforum. When i turn off DI, the noise does not occur.

 

Below are two videos demonstrating the issue. You may need to turn the volume up a little.

 

@Matt_Walker any insight on this issue? Would like to get in contact with you to discuss.

 

 

 

Share this post


Link to post
Share on other sites

I have read about it in AVSforum. Don't have that problem with mine. What is your month of manufacture? Could be the first batch had issues.

Share this post


Link to post
Share on other sites

Beng Su - interesting - could please PM me your serial number?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...