Jump to content

Yardbird

Spendor S8 driver replacement? Or something else?

Recommended Posts

Help Please!

 

Hi there,

 

I have just picked up a set of Spendor S8 (not S8e) floor standing speakers which I could not demo at the time of purchase. 

Whilst the speakers sound great and tight with what I would consider good bass response at least to what I've had in the past, I have noticed some annoying vibration coming from one of the woofers. Where it gets tricky is that it seems to be at a certain volume and frequency. Has anyone come across this?

 

I have tried several different music styles and it is not present on most musics; rather Miles Davis (doobop) which is overlaid with early RAP samples so it's bass heavy. 

 

The driver itself seems to be fine otherwise. 

 

Does this sound like a replacement driver (which is discontinued), a connection problem, manufacturing placement issue, baffle issue or a loose wire somewhere? I'm a little stumped on this so any advice would be great appreciated.

 

I am currently running these speakers via a Music Fidelity M6i amp with a Marantz Pearl Lite CD. 

 

Thanks.

Edited by Yardbird

Share this post


Link to post
Share on other sites

First thing, swap the driver out to the other enclosure. Does the fault move with it? Yes? Then most likely driver. If so, send it to somewhere like Speakerbits to get looked at. It might be a piece of muck in the coil gap and therefore an easy repair. Or it might be stuffed, but fault finding is a step by step, eliminate one thing at a time process.

Share this post


Link to post
Share on other sites

Brilliant A9X, will give it a crack later today and see how I get on.

 

Share this post


Link to post
Share on other sites

Glad to help. Post your results and we'll work from there.

I generally post only every few days, so sorry if I'm slow in responding.

Share this post


Link to post
Share on other sites

Is the woofer in the other speaker doing it as well or only in one speaker

Share this post


Link to post
Share on other sites

Cafe67 defiantly only one woofer. It's seems to come with music that has plenty of bass. 

Share this post


Link to post
Share on other sites


A9X I have swapped out the woofer and it has followed the crackle across to the other speaker. So at least I know that it's defiantly that driver. All leads and connections look to be tight and correct. 

I've had a look online to see where I might be able to secure a new driver but can;t seem to see anything available as the drivers have been discontinued for many years now. 

Driver: Spendor SD-08-a No. 19912 0dB

 

Would you recommend a different driver or a speaker doctor? 

Other than this the speakers are great, but it is completely annoying to listen to the speaker vibration. 

Share this post


Link to post
Share on other sites

Check with Andy at Audiofix , they were the spendor dealer for quite some time, may be able help out 

Share this post


Link to post
Share on other sites

Thanks @cafe67. There is a new distributor that I have contacted for a replacement driver and they are looking into it. Do you know if it's okay to replace one or should they be matched? That's assuming I can still buy any. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×