Jump to content

shueardm1

Integra HDMI fault

Recommended Posts

Will be looking to sell my Integra DHC 9.9 pre pro soon to upgrade to ATMOS. I have one lingering issue that will reduce my resale value for sure, was wondering if there is by chance any user with experience, could give me advice, solution.

The HDMI input number 1 is not able to be chosen from within the input assign menu, all others are OK.

Damn, with this and my remote control buttons being gnawed apart by our ( now deceased pet rats ) , the price I get  wont make me too happy I fear

Share this post


Link to post
Share on other sites

I sold my working DHC 9.9 for a song earlier this year, so I feel your pain. I do have a copy of the service manual which describes some HDMI debug modes that might help - I'll try to attach below.

integra_dhc-9.9_Service_Manual.pdf

Share this post


Link to post
Share on other sites

Hi Quark

Thank you for this reference. I have found the section and it looks rather confusing . Will see how I get along when I have time to study it better.

Thank you

Share this post


Link to post
Share on other sites
Quote

 

fixed  this by spraying contact cleaner in it.

Now if only I could get a replacement remote. 

Share this post


Link to post
Share on other sites

Have you tried ebay in the US for the remote?  As some of the amp models are different to ours , try a search using the remote model number

 

Share this post


Link to post
Share on other sites

Holy smokes. That manual makes me appreciate the product a bit more! I think I fried the HDMI out on my Integra and my Marantz. Seems pretty easy to do.

 

I may try the contact spray. 

Share this post


Link to post
Share on other sites


13 hours ago, rawcraftwood said:

Have you tried ebay in the US for the remote?  As some of the amp models are different to ours , try a search using the remote model number

 

I have a saved search happening in my ebay, not getting any hits

Share this post


Link to post
Share on other sites

I have found in the past that you need to go to ebay.com ( not au ), not log in, and try a more specific search.

Here's what I found this afternoon.....10 seconds! ( could have been just lucky I guess )

https://www.ebay.com/itm/Original-Onkyo-Integra-AV-Receiver-Remote-Control-RC-688M-RC1407626-05/113449396236?hash=item1a6a1c680c:g:t0kAAOSwaIpcEsWt:rk:1:pf:0

and use your own battery cover!

or possibly this one will work 

https://www.ebay.com/itm/New-Original-INTEGRA-RC-688M-OEM-A-V-Receiver-Remote-Control/202551659984?hash=item2f29050dd0:g:GLoAAOSwFlJcKFzV:rk:2:pf:0

 

 

Edited by rawcraftwood

Share this post


Link to post
Share on other sites
13 hours ago, rawcraftwood said:

Here's what I found this afternoon.....10 seconds! ( could have been just lucky I guess )

cheers.

I should clarify. Yes that one I have seen on ebay already and am considering buying it. The thing is my remote is model RC-691M and that one is 688M. There seems only one minor difference with one button but I was still concerned, who knows, it may not work at all.?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×