Jump to content

Sign in to follow this  
petetherock

Oppo Uhd 4K Player

Recommended Posts

12 minutes ago, lordvader82 said:

Does this mean existing 205's will appreciate in value?
:(

 

I'd think concern over player support would depreciate the units value rather than supply vs demand appreciating it. 

Share this post


Link to post
Share on other sites
28 minutes ago, lordvader82 said:

People like me rushing to buy one ;)

A lot of money to buy on impulse ; maybe determine if its .a good system fit . Coincidentally  the recent discovery of 4k ISO playback by Tasso could conceivably be Oppo bucking the system one last time as it did with the bd95 ISO  firmware before they were put in line :thumb:

Remember its a Chinese company with no compunctions about Hollywoods rules as its not making anymore bda licensed players :cool:

Of course disc playability in this 4k era could force a firmware upgrade eventually so the point may be moot..

That iso firmware helped sell my 95 though ; i should mention :)

Share this post


Link to post
Share on other sites

So I lodged a ticket with Interdyn and they advised me to clear the persistent memory and try discs again. Didn't work. I also tried Star Trek Into Darkness, and it does not spin up either. All come up as Unknown Disc. Have reported my findings, will see what they come up with next. 

Share this post


Link to post
Share on other sites


42 minutes ago, BuffySlayer said:

So I lodged a ticket with Interdyn and they advised me to clear the persistent memory and try discs again. Didn't work. I also tried Star Trek Into Darkness, and it does not spin up either. All come up as Unknown Disc. Have reported my findings, will see what they come up with next. 

did they also ask you to do a factory reset. along with clearing persistent memory its something i always do post updates :)

Share this post


Link to post
Share on other sites

No, they've asked me to log the faults on a USB stick and send them the files. Will do that, and try the reset also, thanks. 

Share this post


Link to post
Share on other sites
28 minutes ago, BuffySlayer said:

No, they've asked me to log the faults on a USB stick and send them the files. Will do that, and try the reset also, thanks. 

yep have done that once too. and got a response pretty quickly to resolve so fingers crossed for you :)

Share this post


Link to post
Share on other sites
On 03/04/2018 at 3:16 PM, ward0112 said:

I have my Oppo 203 connected to my Denon 6400, which connects to my JVC 7900.

 

I also have a 4K Apple TV and my question is what is the best way to hook up my apple TV. Should I connect it to the HDMI in on the Oppo 203 or just plug it straight into the Denon?

 

Will the Oppo 203 improve the picture displayed by the Apple TV. It is mainly used to stream content, and to access mkv held on a NAS network drive.

 

Didn't think this question was worthy of a full separate post

If this was my system where I run 21:9 (projector with anamorphic lens), then yes, there is clear advantage to running a device like Apple TV into the back.  On a standard 16:9 system, probably not unless you noticed a black level shift or some of the issue that might be correctable with the user controls in the OPPO.  The OPPO might or might not provide a solution.  As suggested, plug and play directly into the projector and test for yourself.    

Share this post


Link to post
Share on other sites


I run my AppleTV through the Oppo 203's HDMI input for 2 reasons.

 

There's a bug in the way my Sony projector and AppleTV handle Dolby Vision content (up till 11.2.5) which causes black screen dropouts - while audio is playing. And also because I can use Oppo HDR Tone Mapping on the AppleTV.

 

 

Share this post


Link to post
Share on other sites
15 hours ago, :) al said:

yep have done that once too. and got a response pretty quickly to resolve so fingers crossed for you :)

Well I tried factory reset, but no good. So I've sent the 3 files to be looked at. 

 

Something weird though, during my testing after updating firmware I put a few discs in the 205, and one that played (Serenity), now doesn't. Doing my head in ?

Share this post


Link to post
Share on other sites
4 hours ago, BuffySlayer said:

Well I tried factory reset, but no good. So I've sent the 3 files to be looked at. 

 

Something weird though, during my testing after updating firmware I put a few discs in the 205, and one that played (Serenity), now doesn't. Doing my head in ?

Well so it's just not me. I posted a few days ago here that my player (205) wouldn't play Startrek-Into Darkness but I tried the 1st movie and it played no problem. Still haven't heard back from Interdyn regarding BR2049, but now that other discs aren't playing I'm guessing they are waiting to fix all issues with one FW update.

Share this post


Link to post
Share on other sites
23 hours ago, SimonNo10 said:

Well so it's just not me. I posted a few days ago here that my player (205) wouldn't play Startrek-Into Darkness but I tried the 1st movie and it played no problem. Still haven't heard back from Interdyn regarding BR2049, but now that other discs aren't playing I'm guessing they are waiting to fix all issues with one FW update.

And this is exactly why I returned my 205.

 

You get all excited to watch a movie that you haven't seen and then it doesn't work on your $2000 disc player.

 

I have both BR2049 and Startrek into the darkness and both work fine on my Pana UB900 and sony X800.

Not surprised at all that Oppo has ceased production. In 2 years from now when a new UHD doesn't work what happens then if support has stopped?

 

 

Edited by Seandres

Share this post


Link to post
Share on other sites


I had a lot of problems with my Pana UB900 locking up on BR discs so it's not just related to Oppo. I ended up returning the Panasonic at JB and getting an Oppo 203. The Oppo has been working fine fingers crossed for the last 6 months!

Share this post


Link to post
Share on other sites
32 minutes ago, Dokken said:

I had a lot of problems with my Pana UB900 locking up on BR discs so it's not just related to Oppo. I ended up returning the Panasonic at JB and getting an Oppo 203. The Oppo has been working fine fingers crossed for the last 6 months!

yes unfortunately if you check ub900 owner threads either local or overseas, they are also susceptible to this kind of thing. its no different to early days of blu-ray if people remember. and with new titles for a while ending updates to play :) even till quite late in stage. I remember a lord of rings one of the last ones on blu-ray not even being able to get past the menu title screen :D

 

re future support basically any issues will need to be supported with our statutory consumer laws even out of warranty for a while so will follow up myself hopefully by that stage uhd is pretty stable anyhow :)

Share this post


Link to post
Share on other sites

I know it sounds ridiculous but try cleaning the disc.  UHD discs seem to have a film or residue that that the Oppo struggles with.  This applies even to brand new discs.

Do a full reboot, take the player out of network standby mode and turn it off.  

Save your settings to a USB and do a factory reset; reinstall settings and try disc again.

If you've tried all those and discs still don't play you probably need to get your player fixed.

Share this post


Link to post
Share on other sites
On 07/04/2018 at 9:47 AM, blairy said:

I know it sounds ridiculous but try cleaning the disc.  UHD discs seem to have a film or residue that that the Oppo struggles with.  This applies even to brand new discs.

Do a full reboot, take the player out of network standby mode and turn it off.  

Save your settings to a USB and do a factory reset; reinstall settings and try disc again.

If you've tried all those and discs still don't play you probably need to get your player fixed.

Did as you suggested, discs still don't play. I can hear the laser ticking away as it tries to read the discs, but after approx 80 seconds, the unknown disc error comes up. Other 4k discs play without issue. 

Share this post


Link to post
Share on other sites


Why don't people return the discs that won't play, rather than the player?

 

It seems that discs not playing is an issue across brands, which suggests (to me) that the issue could be disc quality rather than player quality.

Share this post


Link to post
Share on other sites
14 minutes ago, BuffySlayer said:

Did as you suggested, discs still don't play. I can hear the laser ticking away as it tries to read the discs, but after approx 80 seconds, the unknown disc error comes up. Other 4k discs play without issue. 

 

9 minutes ago, Benje said:

Why don't people return the discs that won't play, rather than the player?

 

It seems that discs not playing is an issue across brands, which suggests (to me) that the issue could be disc quality rather than player quality.

Took a while...BUT...bingo...

The penny has finally dropped...

Share this post


Link to post
Share on other sites

So I had my first major glitch last night.  The movie just paused and initially I thought I had bumped the remote.    Nothing would get this to continue to play including, ejecting the disc, clearing persistent memory and restarting the player.  When it did start again, it skipped to the end of that chapter.  The annoying part is that I have watched this disc right through at least twice without out issue.  Disc was SW TLJ, of course...

Edited by CAVX

Share this post


Link to post
Share on other sites
On 11/04/2018 at 5:27 PM, Benje said:

Why don't people return the discs that won't play, rather than the player?

 

It seems that discs not playing is an issue across brands, which suggests (to me) that the issue could be disc quality rather than player quality.

Because maybe, just maybe we have already tested it on a different player and it works fine.

 

 

Edited by Seandres

Share this post


Link to post
Share on other sites

Update: And watched the same title the next night and it played with no problems, so I don't know what is going on here.  Player has not missed a beat since.  

Share this post


Link to post
Share on other sites
On 13/04/2018 at 9:01 AM, CAVX said:

So I had my first major glitch last night.  The movie just paused and initially I thought I had bumped the remote.    Nothing would get this to continue to play including, ejecting the disc, clearing persistent memory and restarting the player.  When it did start again, it skipped to the end of that chapter.  The annoying part is that I have watched this disc right through at least twice without out issue.  Disc was SW TLJ, of course...

going forward the safe thing I think is to log all issues on oppo website

 

http://support.interdyn.com.au/support/tickets/new

Share this post


Link to post
Share on other sites
On 15/04/2018 at 12:12 PM, :) al said:

going forward the safe thing I think is to log all issues on oppo website

 

http://support.interdyn.com.au/support/tickets/new

Just added to my ticket (still open and haven't received any feedback), I have now purchased more 4k discs and none of them play! This is getting really annoying. No problems with any discs prior to latest firmware update, now 3 out of 4 not playing!!! 

Share this post


Link to post
Share on other sites
17 hours ago, BuffySlayer said:

Just added to my ticket (still open and haven't received any feedback), I have now purchased more 4k discs and none of them play! This is getting really annoying. No problems with any discs prior to latest firmware update, now 3 out of 4 not playing!!! 

id just be going back to retailer if had non response. sounds like you have a dud. Id  take discs with you ....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DubbyMcDubs
      Item: Oppo UDP-203 + Genuine Rack Kit
      Location: Central Coast NSW
      Price: $2,000 ono
      Item Condition: Excellent
      Reason for selling: No longer required + Need funds for other upgrades
      Payment Method: Pickup - Cash, EFT, Paypal + 2.6%, COD Only
      Extra Info:
       
      I purchased this player just over a year ago for my HT build, which not completed so this player has had very little use (one bluray and a few SACD’s).  Now, I am ripping all my movies to a file server so have no use for it in the HT.  I also need the funds for other upgrades.
       
      It’s in new condition apart from a small scratch on the face of the device, but it is only noticeable when close up and in a certain light. Comes with the genuine Oppo rack mount kit, which was an additional option at the time of purchase. I no longer have the original box but still have all the accessories (with small box) and Oppo bag.
       
      Photos: 






    • By Isaac Otaiza
      Item: Blade runner 2049 4k UHD 
      Location: gold coast
      Price: $15
      Item Condition: used once only
      Reason for selling: No longer required
      Payment Method: Pickup - Cash, Paypal, COD Only
      Extra Info:
       
      Photos: Advertisements without photos of the actual item will not be approved.

    • By angmavris
      Item: Panasonic UB900 4k UHD Blu-ray player
      Location:Sydney
      Price: $350 price reduced  
      Item Condition: Excellent hardly used 
      Reason for selling: NRQ 
      Payment Method: Pickup - Pick up or buyers expense Cash, Paypal, COD Only
      Extra Info:: Has hardly been used . remote was damaged by child ordered a new one see attached photo not the one that one that come with the unit but does control unit and works fine  , power cable and original packaging  and all paper work included that came with unit 
      https://www.techradar.com/au/reviews/audio-visual/blu-ray-players/panasonic-dmp-ub900-1312558/review
      Photos: Advertisements without photos of the actual item will not be approved.
       
       
       



    • By Stephen0804
      Item: LG UP970 4K HDR Blu-ray player
      Location: Aberfoyle Park, SA
      Price: ~ $200 O.N.O. 
      Item Condition: Very Good, not used often 
      Reason for selling: got a new tv and am upgrading to get the features i require 
      Payment Method: Pickup - Cash, Paypal, COD Only
      Extra Info: supports Dolby Vision and hdr, has Youtube and Netflix apps. 
      would have to check if i have original box but i have everything that came with it. 

      Photos:

×
×
  • Create New...