Jump to content

Sign in to follow this  
okitoki

Epson Tw3600 Menu

Recommended Posts

Hi all

Just picked up a used TW3600 to replace TW5200 and so far I'm trilled with the result...

However, while trying to adjust the display using my wow disc, I've noticed most of the signal menu were grayed out and unable to select. Also could not select HDMI range too....

Is this something normal and locked out due to advance feature settings?

Also noted there were slight flickering in Eco mode, but is gone when in Normal mode. I read its a common issue with this model and should disappear after a few hours used on normal? Bulb I have is a new "genie" lamp from amazon while I'm waiting for my original epson lamp to arrive.

Thank you

Share this post


Link to post
Share on other sites

Hi all

Just picked up a used TW3600 to replace TW5200 and so far I'm trilled with the result...

However, while trying to adjust the display using my wow disc, I've noticed most of the signal menu were grayed out and unable to select. Also could not select HDMI range too....

Is this something normal and locked out due to advance feature settings?

Also noted there were slight flickering in Eco mode, but is gone when in Normal mode. I read its a common issue with this model and should disappear after a few hours used on normal? Bulb I have is a new "genie" lamp from amazon while I'm waiting for my original epson lamp to arrive.

Thank you

Hi,

Are you using the projector with a PC?

Look at page 28 of your manual; "Not displayed when image signals are being input from a computer".

JSmith :ninja:

Share this post


Link to post
Share on other sites

Ah well... There we go :) using my htpc connected via my pioneer sc1223...

Did not come with manual when I bought it..... And my google skill did not find any on it :)

Thank yor for clearing it up

Share this post


Link to post
Share on other sites

Thank yor for clearing it up

No worries. :)

I gather the reason is you can access similar controls via the connected PC itself. ;)

JSmith :ninja:

Share this post


Link to post
Share on other sites


While you are here... Is there an option for HDMI control for the 3600? On the 5200 it would turn the avr on when first powered up...

Thanks

Share this post


Link to post
Share on other sites

While you are here... Is there an option for HDMI control for the 3600? On the 5200 it would turn the avr on when first powered up...

Thanks

Not sure mate... busy watching cricket now. Australians have been dropping like flies... :o

Your product manual here;

http://tech.epson.com.au/downloads/category.asp?sCategory=Projector&id=eh-tw3600&SelOS=Y

JSmith :ninja:

Share this post


Link to post
Share on other sites

Ah... Cheers for the link....

Good luck to the Aussies :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...