Jump to content

Sign in to follow this  
jd71

Samsung P9 (ps50p91fdx) Owners Thread

Recommended Posts

Jomac, How long have you had it for?

less than 2 weeks now .

Share this post


Link to post
Share on other sites
less than 2 weeks now .

You are quite within your rights to demand that the GG replace the screen. Your contract is with them not samsung and if the screen isn't performing as it should THEY have the statutory responsibility to replace it.

Myer swapped my screen no questions asked and I'd had it for about 4 weeks.

Of course if your happy to have it repaired thats fine but don't let retailers fob you off.

Share this post


Link to post
Share on other sites

Is it me or does DTV look kinda "unnatural" at times on this set? This is my first large screen TV and sometimes even on HD channels there seems to be an un-eveness in the skin tones if I look closely. If I were to stand far away from the TV, approx 3m, I can't see the difference.

The uneven texture is especially noticable when I watch the cricket - the grass, the players faces all look a tad off. Btw, there doesn't seem to be any problems at all with the quality of the picture for Blu-ray movies.

Is there anything with the settings I can do to get a better pic?

Share this post


Link to post
Share on other sites


you're not meant to watch a 50" screen up close ;)

Hehehe, yeah. But even from far away the grass is texture does seem a bit uneven - don't know if they broadcast the cricket on HD but yeah, that seems to be the worst atm.

I've just entered in PeeJay's settings - there seems to be a bit of an improvement. I shall test the cricket on it tomorrow.

Is there a way to save the picture settings to a new profile? I've checked the manual but can't seem to find anything on it.

Edited by antler

Share this post


Link to post
Share on other sites
Have also notice another big problem with all HDMI inputs , I am getting an interference around the edges of all characters as the the set heats up , It looks like the effect you would get in paint shop pro etc if you used the magic wand to select the edges of figures.

If I let it cool down and switch back on it's ok for about 3 minutes and gradually gets worse as it heats up again.

I have plugged the same source into my old LG and no problems on HDMI , using the same source into the samsung on component , SVHS or standard AV is ok but 1080 is not usable with this problem.

Anyone seen this problem or have any suggestions other than take it back ?

Hi mate, I've got my PS3 hooked up via HDMI and have the same thing happen when the unit heats up. On the PS3, games and Bluray movies play fine with no sign of this, but as soon as I'm in the XMB (the PS3 home menu), as well as viewing media (vids or pics) the problem is there.

I tried a standard DVD without the PS3 upscaling it and no dots (ran at standard definition though), but as soon as I upscaled it with the PS3, the dots appeared. I think it may have something to with upscaling, whether its by the media player (PS3 in this case) or the TV I don't know.

Has anyone got this tv with a PS3 connected via HDMI? Do you have this issue? If not, what settings are you using? (for both the PS3 and TV)

Jomac, have you found out anything more in regards to this? (from Samsung, The Good Guys etc...)

Share this post


Link to post
Share on other sites
Hi mate, I've got my PS3 hooked up via HDMI and have the same thing happen when the unit heats up. On the PS3, games and Bluray movies play fine with no sign of this, but as soon as I'm in the XMB (the PS3 home menu), as well as viewing media (vids or pics) the problem is there.

I tried a standard DVD without the PS3 upscaling it and no dots (ran at standard definition though), but as soon as I upscaled it with the PS3, the dots appeared. I think it may have something to with upscaling, whether its by the media player (PS3 in this case) or the TV I don't know.

Has anyone got this tv with a PS3 connected via HDMI? Do you have this issue? If not, what settings are you using? (for both the PS3 and TV)

Jomac, have you found out anything more in regards to this? (from Samsung, The Good Guys etc...)

I was at a retravison in clayton VIC it had the exact same problem on the 50inch floor stock model. It was playing Spiderman 3 via samsung Blue ray HDMI. to me it looked to effect the white portions of the picture, very wierd i'd put it down to a manufacturing fault and contact Samsung.

Share this post


Link to post
Share on other sites

I've had my ps50p91fdx for 7 weeks now and have no real major complaints. bought it for $3500 back in november 07 so didn't get as good a price as ppl who have bought it more recently.

Anyway I have my samsung blu-ray bdp1400 connected to it via an onkyo 875. Picture quality is great. I used the thx optimiser on starwars dvd to adjust my contrast, brightness etc settings.

I also have my macbook pro connected to the p9 using a dvi to hdmi cable. Picture quality was on par with the my blu-ray player when watching a 1080p version of transformers. the macbook pro even let me change my output settings to 24hz which the P9 managed to pick up. My one complaint is that when using the output from my macbook pro the image on screen does not fill the full screen with there being a 1cm gap on each side. This is probably due more to my settings on the macbook pro rather than the P9 itself.

I do hear cracking noises after i have turned it off, which appears to be the tv "settling" but this always happens with things that run hot and are then turned off to cool down.

Also the remote response is terrible slow. but other than that very satisfied with the TV.

Share this post


Link to post
Share on other sites


I've had my ps50p91fdx for 7 weeks now and have no real major complaints. bought it for $3500 back in november 07 so didn't get as good a price as ppl who have bought it more recently.

Anyway I have my samsung blu-ray bdp1400 connected to it via an onkyo 875. Picture quality is great. I used the thx optimiser on starwars dvd to adjust my contrast, brightness etc settings.

I also have my macbook pro connected to the p9 using a dvi to hdmi cable. Picture quality was on par with the my blu-ray player when watching a 1080p version of transformers. the macbook pro even let me change my output settings to 24hz which the P9 managed to pick up. My one complaint is that when using the output from my macbook pro the image on screen does not fill the full screen with there being a 1cm gap on each side. This is probably due more to my settings on the macbook pro rather than the P9 itself.

I do hear cracking noises after i have turned it off, which appears to be the tv "settling" but this always happens with things that run hot and are then turned off to cool down.

Also the remote response is terrible slow. but other than that very satisfied with the TV.

hey, are you running hdmi into and out of your receiver or component in and hdmi to tv,its just i am looking to upgrade to bd soon where did you get your bdp 1400 from and how much,are you happy with it.cheers clarky

Share this post


Link to post
Share on other sites

Hey guys,

My folks just purchased this tv today and it arrives in a few weeks time.

Just a quick question. What is the USB input for?

Is it a DivX, mp3, etc port?

Cheers!

Share this post


Link to post
Share on other sites
What is the USB input for?

Is it a DivX, mp3, etc port?

Cheers!

Firmware updates ;-)

Share this post


Link to post
Share on other sites


I was at a retravison in clayton VIC it had the exact same problem on the 50inch floor stock model. It was playing Spiderman 3 via samsung Blue ray HDMI. to me it looked to effect the white portions of the picture, very wierd i'd put it down to a manufacturing fault and contact Samsung.

I wouldn't call this a problem at all! After seeing this post, I turned on the TV, watched it for around 1hr and switched over to the PS3 (connected via HDMI). The effect you're probably seeing is the reflection of the text on the back panel of the TV and being illuminated by the light. This gives white text a cloudy look around the edges. If you stand around 1.2m away from the screen you wouldn't even notice it - even if you looked hard for it! I had to stand less than this distance and concentrate on the edges to see this.

As far as I'm aware this reflection problem is present in most plasmas out there (except for the Pioneer one - don't know how they get rid of it lol). I had a look at the Panasonic one a couple of weeks back and it had the same problem.

Edited by antler

Share this post


Link to post
Share on other sites
Firmware updates ;-)

The USB port can also be used to view JPEG images, and listen to MP3 files.

Share this post


Link to post
Share on other sites
I wouldn't call this a problem at all! After seeing this post, I turned on the TV, watched it for around 1hr and switched over to the PS3 (connected via HDMI). The effect you're probably seeing is the reflection of the text on the back panel of the TV and being illuminated by the light. This gives white text a cloudy look around the edges. If you stand around 1.2m away from the screen you wouldn't even notice it - even if you looked hard for it! I had to stand less than this distance and concentrate on the edges to see this.

As far as I'm aware this reflection problem is present in most plasmas out there (except for the Pioneer one - don't know how they get rid of it lol). I had a look at the Panasonic one a couple of weeks back and it had the same problem.

This is no reflection problem it is a real problem that is very visable , obviously your TV is ok but mine and some others aren't , I can be 4 meters away and see it very clearly.

I know the reflection effect you are talking about in plasmas , this is nothing even close to what we are seeing or talking about .

Ags : I spoke to Hills again after stooge007 suggested I was within my rights to demand a replacement , they told me the Tech would either fix it or arrange replacement TV , hopefully will hear back this week , They have ordered a new HDMI board just in case .

Don't worry I will let everyone know the outcome.

Share this post


Link to post
Share on other sites

Man this forum is great! I'll be buying this plasma in the coming weeks and used this site extensively to find out which plasma or LCD to get. :)

I rang a few goodguys here in vic and managed to get it or $3050 with just the standard 2 year warrenty so if anyone else is also looking, make sure you ring around! Extended warrenty is 3yr-$329, 2yr-$229 1yr-$149 according to Goodguys for anyone elses info.

Now to try and sell my LCD that I'll be getting with it....

Edited by xplosv

Share this post


Link to post
Share on other sites


hey, are you running hdmi into and out of your receiver or component in and hdmi to tv,its just i am looking to upgrade to bd soon where did you get your bdp 1400 from and how much,are you happy with it.cheers clarky

Yep. Running a hdmi cable to the AVR from the bdp, and a hdmi cable from the avr to the P9. I got my bdp from Jbhifi for $560.

Share this post


Link to post
Share on other sites
I rang a few goodguys here in vic and managed to get it or $3050 with just the standard 2 year warrenty so if anyone else is also looking, make sure you ring around! Extended warrenty is 3yr-$329, 2yr-$229 1yr-$149 according to Goodguys for anyone elses info.

check out this thread ;)

http://www.dtvforum.info/index.php?showtopic=57822

Now to try and sell my LCD that I'll be getting with it....

although RRP is $1,199, these are selling in stores for < $900.

so you may not get as much for it as you think :(

Edited by Stooge007

Share this post


Link to post
Share on other sites

Hey Guys,

I just rang tech support for my p9 and will be getting someone to look at it this week. Is anyone still having a problem with the buzzing sound from their p9? :)

I just ignored it for a few weeks, but after hearing my sisters plasma.....I decided its a little too loud. You can hear it from 4 metres away compared to my sisters whose tv you have to put your ear up to the set,

Share this post


Link to post
Share on other sites

Hey Guys

I purchased the ps50p91fdx along with a pioneer DV400v upscaling player and a HDMI cable and surge protector and all seems well with the Telly, no strange buzzing noise or anything and the picture looks good. (i have had it about ten days).

I am wondering if anyone has any suggestions for the problem i am experiencing when i play a DVD with the player set to 1080p i get a flicker that is like a burst of static and also bright areas (especially peoples faces) seem to have a really bright outline around them. Someone mentioned this above while using another device to upscale to 1080p.

Currently i am just using 1080i setting on the player and things look fine but i would like to give the 1080p a go and try it out for a while (those static burst make me jump everytime as they are really loud!)

Does anyone have any suggestions on how to fix this problem?

P.S. There is no users thread on this dvd player so maybe my experience could be a heads up to those thinking of connecting these two together.

Share this post


Link to post
Share on other sites

Not sure about that particular DVD player, or the static bursts that you mention - but if you haven't done so already, definitely start with turning OFF some of the TV picture enhancements, like dynamic contrast, DNIe etc in movie or standard mode only. Makes a huge difference in some cases.

Have a play with turning upscaling on/off from the DVD player too - honestly, using the PS3 for dvd playback i'm still a bit undecided as to how much difference it makes, TV does a good job at upscaling as it is and it may just produce unnecessary artifacts.

P

Share this post


Link to post
Share on other sites
Hey Guys

I purchased the ps50p91fdx along with a pioneer DV400v upscaling player and a HDMI cable and surge protector and all seems well with the Telly, no strange buzzing noise or anything and the picture looks good. (i have had it about ten days).

I am wondering if anyone has any suggestions for the problem i am experiencing when i play a DVD with the player set to 1080p i get a flicker that is like a burst of static and also bright areas (especially peoples faces) seem to have a really bright outline around them. Someone mentioned this above while using another device to upscale to 1080p.

Currently i am just using 1080i setting on the player and things look fine but i would like to give the 1080p a go and try it out for a while (those static burst make me jump everytime as they are really loud!)

Does anyone have any suggestions on how to fix this problem?

P.S. There is no users thread on this dvd player so maybe my experience could be a heads up to those thinking of connecting these two together.

Hey slippery,

I had a similar problem with my PS3 hooked up to the tv... I was getting static and loss of signal - i.e. intermittenly just cut out.. I also couldn't display anything on 1080p..

Solution: went and a bougth a new cable and all was fine..

Share this post


Link to post
Share on other sites
Hey slippery,

I had a similar problem with my PS3 hooked up to the tv... I was getting static and loss of signal - i.e. intermittenly just cut out.. I also couldn't display anything on 1080p..

Solution: went and a bougth a new cable and all was fine..

I can second that too, changed the cable to belkin PureAV cable and it fixed the problem. Slippery I got the same setup as you do with the same pio DVD player.

Share this post


Link to post
Share on other sites

Hi dptdp, I have a pure AV Belkin HDMI cable - did yours run perfect straight out of the box?

Tried turning off all features as suggested by PJ but no luck, the burst of sound is so loud that my old lady just yelled at me from the 2nd level of our house to "stop trying to break the TV"

Edited by slippery

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...