Jump to content

Leeming42

Members
  • Content Count

    22
  • Joined

  • Last visited

Community Reputation

5 Neutral

About Leeming42

  • Rank
    10+ Post Club

Profile Fields

  • Location
    Western Australia
  • Country
    Australia
  • First Name
    Steve

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Further information: Price drop, need to sell to finance new project. Am open to reasonable offers Bought January 2019. Ortofon OM 10 Cart. Maybe 150 hours since new. Perfect condition. Have all paperwork Photos: Advertisements without photos of the actual item will not be approved.
  2. Hi Guys, thanks to all for the input from this thread previously. Finally fixed. The Rotel amps can be connected via a small wire, which then allows you to use a trigger switch so that both the pre and power amp, can be turned on simultaneously with the remote supplied with the power amp.. Disconnected the wire, no more hum. Happy days. Thanks for all your suggestions guys
  3. Finally fixed. The Rotel amps can be connected via a small wire, which then allows you to use a trigger switch so that both the pre and power amp, can be turned on simultaneously with the remote supplied with the power amp.. Disconnected the wire, no more hum. Happy days. Thanks for all your suggestions guys
  4. Hi thanks for the input. There is no USB lead connected. The Turntable is an Essentials 3 digital, I use to run it through the Stream Magic via a Toslink cable with the Stream Magic switched to pre amp mode, using the built in phono stage on the turntable. I have now switched the Stream Magic off the pre amp setting, added a Rotel pre amp, taken out the Toslink cable switched the built in pre amp off, and connected the turntable to the pre amp the RCA leads. I disconnected the ground wire from the earth on the pre amp as it increased the hum.
  5. Was originally running the turntable through the Stream Magic via a Toslink cable, was not noticing the noise at that point. Put the Pre amp in the system in November and the buzz started. Disconnected the ground wire from the preamp and the buzz reduced but is still there at volume. Cannot hear it when an album is playing. Buzz increases with volume.
  6. Cheers, now have a couple of things I can try. Fingers crossed
  7. Thanks will give that a go
  8. As above, Stream Magic, disconnected no change
  9. Will give it a go Just disconnected the Stream Magic, made no difference unfortunately.
  10. I have an issue with turntable buzz as you can see from the title. My turntable is a Project Essential 3. My pre amp is a Rotel RC 1590. My power amp is a Rotel RB 1552 Mk II. My speakers are B&W 683s. I also have a Cambridge Audio Stream Magic 6 in my system no hum when I am using that. I have tried all the usual fixes, plugging everything into the same power outlet making sure the earth is connected, ( actally when I take the earth off the amp the humm reduces), checking for loose connections etc, Still humming. Any suggestions would be appreciated. Cheers Steve
  11. I have the B&W 683 S2's with a Rotel RC 1590 pre and a Rotel RB 1552 Mk 2 works really well.
  12. Thanks for the feedback guys, I notice a couple of you are recommending direct drive turntables. I have always been under the impression, rightly or wrongly that a belt drive is the way to go?
  • Classifieds Statistics


    Currently Active Ads

    Total Sales (Since 2018)

    Total Sales Value (Last 14 Days)

    Total Ads Value (Since March 2020)
×
×
  • Create New...