Jump to content

nmathavan

Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About nmathavan

  • Rank
    10+ Post Club

Profile Fields

  • Location
    Melbourne
  • Country
    Australia

Recent Profile Visitors

639 profile views
  1. nmathavan

    Re Xindak PA1 power amp and CA1 pre amp

    Thanks For all , yes I go ahead with more reliable system for far less price. Regards Matt
  2. Hi fellows I came across above combo for 4000$ Has anyone used or listened to above xindak products? How they sound ? And any reliability issues in long run with these products? Any comparable products in other brands ? Any wisdom thoughts will be appreciated Thanks Matt Happy Christmas and safe Holidays folks
  3. nmathavan

    Transformer humming noise Luxman 590ax

    @ Happy -Yes it dose hum without anything connected . @ 125dBmonster Is there any diy to fix it or just ignore it and Get some more volume with amp ? Anyway that’s what I am doing at this stage . Will any vibration dampers will help ?
  4. nmathavan

    Transformer humming noise Luxman 590ax

    Thanks I will try that option and see
  5. nmathavan

    Transformer humming noise Luxman 590ax

    Hi Thanks for your reply I already got a solar panels at my place which were installed nearly 3 yrs ago . So if that’s a issue then I should have that problem before as well? I am using power generator P10 in my system so I hoped that would cancel any dc voltage in my line . Regards Matt
  6. Hi fellows I need some help to figure out why I am getting transformer ‘hum’from my Luxman 590ax amp. I purchased it nearly a year ago and paired it with Luxman D06u SACD Player/dac and driving Opera Grand Callas speakers . All my system power go through PSAudio P10 power plant. Initially I didn’t get any noticeable hum with amp but in last few months I can notice a ‘hum’ from my amp. I am not hearing any noise from speakers only from amp and I can feel some fine vibration when I touch the top panel of amp. I couldn’t figure out why it’s happening? . is that a normal issue for this particular amp on long run ? Or something needed to look in for a service? Thanks for your time and any valuable advice will be appreciated Regards Matt
  7. nmathavan

    Alternatives to class A?

    I gone through same situation. I ended up with options krell vs parasound. Krell sets its bias according to output and Parasound Jc1 monoblocks offer high and low bias setting . Check them out and see . Love my Class A 😃 Sent from my SM-N910G using Tapatalk
  8. nmathavan

    New Member

    HI Fellows GREETINGS FROM A NEWBIE THANKS FOR ACCEPTING ME IN STEREO NET COMMUNITY. I AM TECH FREEK SINCE MY CHILDHOOD but I didnt pursue my carrier in that field .But it always stayed with me as a hobby. I remember that i bulid my first amplifier at mu age of 10.Nowerdays didnt get much time but i always love to SHARE MY EXPERIENCES. Hope you guys dont mind😃
×