Sign in to follow this  
Followers 0
skipppy

Denon AVR-3312

4 posts in this topic

Denon AVR-3312

 

Well after 2 measly years of service my Denon has decided to loose sysc with audio through HDMI cutting in and out and sometimes not working at all just the picture. I also get this fantastic click click sound as if you are changing inputs

 

Has anyone else had the same issues?

 

Not being the wealthiest man on the planet i am now torn, to fix the 2 yr old amp or just buy something entry level???

Share this post


Link to post
Share on other sites
On 10/19/2016 at 1:56 AM, skipppy said:

Not being the wealthiest man on the planet i am now torn, to fix the 2 yr old amp or just buy something entry level???

Here you go, perfect. ;)

 

Share this post


Link to post
Share on other sites

Have you tried swapping out the HDMI cable? 

Edited by thathifiguy
1 person likes this

Share this post


Link to post
Share on other sites

I have the 2312 model and too get that dreaded clicking sound the sound drops out but for only the 2 surround speakers.

 

Many Thanks  : )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.